Sun, Jul 1
Fri, Jun 29
Thanks for the help kristof. I couldn't find the documentation to bound input of sysctl's but I definitely agree it's better to validate it on entry.
Updated with help from kristof to validate sysctl on change.
Fri, Jun 22
Thu, Jun 21
So, you're saying the we need testers for this configuration before we put it in the handbook as official instructions?
Wed, Jun 20
Applied all the modifications suggested by @bcr . Thank you!
The line-breaking were a first attempt to handle too-long lines, your solution is far better. A couple of comments:
Jun 18 2018
A few suggestions, mostly about line breaks with a few textual corrections.
Jun 9 2018
I'd prefer the sysctl to reject values that are out of range.
What do you think about this: https://people.freebsd.org/~kp/patches/D14536.patch ?
Jun 8 2018
Update sysctl to be based on decimal dscp value instead of toggle
May 22 2018
May 17 2018
May 15 2018
May 14 2018
May 13 2018
I think we can try to test this with wider auditory.
May 11 2018
yeah I must've forgotten to do that sorry. Thanks!
style(9) issue - should not have trailing whitespace (tabs or spaces) at the end of the line
I will clean these up before commit
I added the pid in rS333489, as well as the pid for the LAN7801 (which Microchip sent me after the co-op term ended). I'll commit the driver with LAN7800 support only, then see if the 7801 "just works" or if we need additional changes.
May 10 2018
A new version with a more concise text in the first part is available.
Correction of the first part. The original text has been restored till the slapd.ldif example. The first section of slapd.ldif configuration has been significantly shortened, and many not necessary flaws have been deleted. If this is ok, the remainder can be modified following the same method.
The whole chapter
is also attached.
May 9 2018
Is it planned to address the client side (e.g., nss-pam-ldapd) or just the server?
May 8 2018
Looks good to me.
May 3 2018
May 2 2018
changed the file name, and variables. build passes.
May 1 2018
I guess muggle is right out :)
After a brief IRC discussion it sounds like if_muge is the preferred option.
Aside, this exercise highlights that we need a man page for the new driver too.
Looking at existing examples,
|if_aue||ADMtek AN986 Pegasus|
|if_axge||ASIX AX88178A/AX88179 GigE|
|if_cdce||USB Communication Device Class|
|if_cue||Computer Access Technology Corporation (CATC) USB-EL1210A|
|if_ipheth||Apple iPhone / iPad tethered Ethernet|
|if_kue||Kawasaki LSI KL5KUSB101B|
|if_usie||No man page|
What is the preferred name for this driver? I basically used LAN78XX because that was the naming scheme linux went with. It's kind of confusing as this driver is used for also LAN7515 on raspberry pi's. My suggestion is: if_umicro.c since it's for microchip, and it starts with a u like other FreeBSD's usb-to-ethernet drivers. However, that naming doesn't have any info about the model.
more accurate error checking, style fixes.
Added error checking for offset in mii read callback.
Apr 30 2018
Driver seems to follow the yellow brick road of the existing USB ethernet drivers. Some comments added.
lan78xx isn't a very FreeBSD-like device name: It doesn't start with 'u' like most other usb lan drivers and we usually don't name them so directly. History has shown that this driver will either (a) be used for a lan79<mumble> part or the lan7850, for example, will need a new driver. You don't have to rename all the variables / functions, but please consider selecting a different name,
This is the glue needed to build as a ko. If you add it to the KERNCONF file like 'device if_lan78xx # PI3b+ USB NIC' then you build it inline.
Added a few subscribers with USB network experience