- User Since
- Mar 12 2014, 1:00 AM (402 w, 6 d)
Sorry to nitpick a bit more. Please let me know if you'd like me to commit the change.
I don't really like this interface. The name is too general and the interface is kind of simplistic, for example because it can only describe a single contiguous memory region and can't refer to different instances of a device. I'm not what a better interface would look like, I haven't yet read more of the patch series. But I think this deserves some more thought.
Looks ok. I'd explicitly initialize MXPS and NOPS to zero as well.
I believe this is superseded by commit 1d9eae9fb2e2253ca3d3764a5cc7f124b10e358b .
Could you please upload a diff with context?
Make do_config() take a size_t instead.
size_t -> unsigned long
a -> an
Use .Vt for referring to an Elf(32|64)_Chdr
Sat, Nov 27
Fri, Nov 26
Thu, Nov 25
This looks good!
Wed, Nov 24
Attempt to create the alias iff the device unit number is 0.
Go a bit further and create /dev/agpgart%d for all devices, and create the alias
for the device with unit number 0.
Tue, Nov 23
- Fix ip_output()
- Move the mb_unmapped_to_ext() call out of ip6_output_delayed_csum()
P.S., I spent some time trying to replace this implementation with an updated one from NetBSD. Theirs is easier to read and is licensed under BSD 2-clause. It got somewhat messy, though, and wasn't important to my immediate goal, so I dropped it. I think there's also some room for micro-optimizations here, for instance in_pseudo() and in_addword() should probably be inlines. in_pseudo() in particular is dead simple, it's just a ones complement sum:
Mon, Nov 22
Is it sufficient to instead set be_state = IDENT_WAIT in fwctl_inl(), or handle be_state == REQ the same as be_state == IDENT_WAIT in fwctl_outw()?