- User Since
- Aug 2 2014, 12:45 PM (211 w, 17 h)
Fri, Aug 17
Thu, Aug 16
Why not just add evdev and wmt to GENERIC?
Wed, Aug 15
Tue, Aug 14
Tone it down somewhat, mention the firmware.
Mon, Aug 13
Move stuff around.
Move the code to a separate function.
Also update init(8).
Thu, Aug 9
Wed, Aug 8
Done, see https://reviews.freebsd.org/D16627.
This also introduces execute_script() and refactors code a bit. My plan is to commit this part (refactoring) first, and the actual new functionality and man page updates later.
Tue, Aug 7
Sat, Aug 4
Add the extra access(2) checks, as suggested by kib@, and also
apply the same change to the code that runs /etc/rc.shutdown.
Fri, Aug 3
Thu, Aug 2
Of course it's been tested. Shells use the nonblocking mode anyways, though, so they work just fine.
Remove pointless variable.
Wed, Aug 1
Tue, Jul 31
Ok, how about now? I"m not sure about the _BASENAME, tbh.
Add _BASENAME_RTLD and use it in error messages.
Mon, Jul 30
Tue, Jul 24
Mon, Jul 23
To be honest I'm not even sure if it _is_ an issue. It's just something to think about, and preferably test: what happens when you try to boot ZFS mirror with one device missing.
Fri, Jul 20
Jul 19 2018
Jul 18 2018
Without renaming we would have both "kern" and "kernel". In devd.conf(5) man page we already have the "kern" top-level, described as "Events related to the kernel"; leaving the old name would require adding a new top level "kernel" - described as "Also events related to the kernel", I guess?
Jul 16 2018
It's already there :-) I plan to add a few more (HN, DuckDuck go perhaps), but I'd rather to that in a separate commit.
Use https://, as suggested by delphij@.