Page MenuHomeFreeBSD

mmc_helper: add mmc_helper and rename mmc_fdt_helper to mmc_helper
ClosedPublic

Authored by bag_semihalf.com on Aug 18 2021, 8:49 AM.
Tags
None
Referenced Files
Unknown Object (File)
Wed, Feb 21, 10:10 PM
Unknown Object (File)
Fri, Jan 26, 10:55 AM
Unknown Object (File)
Jan 17 2024, 6:00 AM
Unknown Object (File)
Dec 24 2023, 10:35 AM
Unknown Object (File)
Dec 22 2023, 11:36 PM
Unknown Object (File)
Dec 12 2023, 12:27 AM
Unknown Object (File)
Nov 29 2023, 8:46 AM
Unknown Object (File)
Nov 2 2023, 5:28 AM

Details

Summary

Add generic mmc_helper which uses device_get_property api.

Rename mmc_fdt_helper structure to mmc_helper to get rid of redundant code.

Diff Detail

Repository
rG FreeBSD src repository
Lint
Lint Not Applicable
Unit
Tests Not Applicable

Event Timeline

Code looks ok but that will break out of tree drivers (even if I'm sure that no such out of tree drivers using mmc_fdt_helpers exists) so I'm not too sure about this change.

I can add a macro like this somewhere in mmc_fdt_helper.h header, to keep it backwards compatible.

#define mmc_fdt_helper mmc_helper

I can add a macro like this somewhere in mmc_fdt_helper.h header, to keep it backwards compatible.

#define mmc_fdt_helper mmc_helper

Yes please.

I've added the macro. Should I revert the changes in other drivers? I didn't do it now, cause I think this could encourage people to use the new structure.

This revision is now accepted and ready to land.Aug 26 2021, 8:34 AM

I've added the macro. Should I revert the changes in other drivers? I didn't do it now, cause I think this could encourage people to use the new structure.

No, all drivers should use the new struct.

This revision was automatically updated to reflect the committed changes.