- User Since
- Mar 22 2019, 4:46 AM (130 w, 11 h)
Looks fine to me. I would suggest keeping the KASSERT though, it is free and makes the point of failure more obvious if this condition did occur.
This is mostly mechanical. state->dump_bitset should be used inside each minidump_machdep.c, and vm_page_dump everywhere else. The one exception to this is powerpc's dumpsys_scan_pmap() method, which is extended to also accept a bitset argument.
Wed, Sep 15
Tue, Sep 14
Mon, Sep 13
Fri, Sep 10
Rename functions to have a dumpsys_ prefix.
Thu, Sep 9
It is possible that this check would be better placed in the sdhci driver itself, where SDHCI_WILL_HANDLE_TRANSFER() is actually called. This is the only driver that implements this method, however.
Drop include of vm_phys.h from vm_dumpset.h. Include it where it is needed instead.
Wed, Sep 8
Mon, Aug 30
Aug 11 2021
Weird, this didn't get auto-closed.
Switch to just removing the existing redundant capability checks.
Also give pidhashtbl a specific initial value of NULL. NFC, but semantically correct.
Update with markj's feedback. Keep the allproc initialization bit, as it may be checked early by db_ps().
Aug 10 2021
Aug 9 2021
Aug 6 2021
While I did not go over every line in detail, I don't see anything objectionable. The PCIe chapter in the FU740 manual is particularly lacking.
Aug 5 2021
Forgot to hit accept :)
There is a list of gpio drivers in the gpiobus(4) man page. It is not up to date, but you should add an entry for this driver.
Aug 4 2021
Aug 3 2021
Unfortunately, I ran out of steam for this ahead of the release, and the moment has passed.