- User Since
- Jun 2 2014, 4:20 PM (147 w, 3 d)
Wed, Mar 29
Tue, Mar 28
Mon, Mar 27
Fri, Mar 24
Thu, Mar 23
Wed, Mar 22
Same thing 4 times... Maybe a routine would be better?
I generally like this change. We tried very hard to require the system compiler to do the right thing for two reasons back in the day. First, we wanted to make sure a naked cc could just build things so ports would work better. Second, there were several tricky, hard-coded at the time, bits in different builds that got the wrong ABI tags and so wouldn't link (hack.so?) that were a pita to track down... If the latter has been solved, the former does remain. However, I think it's better that we're explicit since it enables a wider range of compiler to build the base system, and the problem of using those compilers with ports is orthogonal. We shouldn't require it any longer since it is standing in the way of making things better. I regret that we decided to do what we did back in the day since it has held back the external-toolchain work on mips a bit.
Mon, Mar 20
Thanks for making the suggested changes...
Fri, Mar 17
Once upon a time this was needed to create the assym.h file that encoded all the struct sizes and offsets the .S files used. No clue why it is here though....
Thu, Mar 16
Tue, Mar 14
Looks like all of Bryan's feedback has been answered, and that answers the questions I had.
Mon, Mar 13
Generally looks good, modulo some of the text. But it's not a text cleanup, per se, so I'm good with this going in.
Sun, Mar 12
I like setting persistent things to NULL after free, but setting local variables to NULL after free on the 'exit' path of the function is actually harmful: Either the compiler will generate code that wastes cycles in what could be a critical path, or it will optimize it away and maybe issue a warning.... Neither outcome is good, and there's no benefit to doing this.
Forget what I said about anything being missing, other than my ability to read for comprehension.
Note that the text doesn't match the description. The description is missing the word 'NULL' I think.
Fri, Mar 10
I'm agnostic to the change.
I get why they are doing malloc(a * b) -> reallocarray(NULL, a, b), but wonder if it would be better to have a wider API that's mallocarray(a,b) if you are looking for syntactic goodness along with your overflow protection....
- Move /etc/ to SRCTOP
- Convert include over to SRCTOP
- Fix two CURDIR references in comments that should be SRCTOP
- Make rescue use SRCTOP
- Fold with usr.bin
- Convert gnu/lib to using SRCTOP
- gnu/usr.bin SRCTOP
Thu, Mar 9
This looks good to my eye. One nit.
Wed, Mar 8
Peter: This seems like a common case (idiom) that we should maybe solve without a huge number of #ifdef INVARIANTS, maybe by a new macro that does the right thing in the !INVARIANTS case?
Tue, Mar 7
Sun, Mar 5
Yea, the _s functions are MS' NIH for other interfaces that had pre-dated their crazy by a lot.
The code and the tests look good.
There's no man page.
Fri, Mar 3
This is fine, though the commit message could use some work.
Wed, Mar 1
Feb 28 2017
Feb 27 2017
I can't think of a better name....
Feb 26 2017
Fix issues raised in the review.
This has been committed, but in different form.
Feb 25 2017
Date: Sat Feb 25 06:11:59 2017
New Revision: 314250
Made suggested changes.
Rename pci_pcie_intr to pci_pcie_intr_hotplug.