- User Since
- May 16 2014, 7:35 PM (278 w, 6 d)
This looks fine to me, but I have no idea why John put PCI_RES_BUS under #ifdef NEW_PCIB instead of defining it always. Also, would it be reasonable to do a separate pass to rename PCI_RES_BUS to SYS_RES_PCIBUS ?
I think it would be fair to remove copyrights from machine/resource.h, instead put the trivial header files into public domain or assign to yourself.
Wed, Sep 18
Tue, Sep 17
I think it is fine.
Why do you need vn_start_write_nb() when vn_start_write() already takes the flag argument ?
Mon, Sep 16
It cannot be defined, but can be declared, same as now. Or I do not understand what you are trying to say.
Sun, Sep 15
Sat, Sep 14
This is not yet updated to pcpu counters, right ?
Build fixes: tb passes.
Fri, Sep 13
Rebase after riscv commit.
I am fine with this version modulo atomic_short.
- Stop overloading KERN_INVALID_ADDRESS for out-of-object error. This breaks other situations, it seems that the best route is to add a new Mach-style error.
- Switch to use switch in signal decoding in vm_fault_trap().
- Do not assume that map == kernel_map implies signo != NULL. copyin faults on user address, but in kernel mode.