- User Since
- Jul 9 2015, 9:56 PM (210 w, 2 d)
Fri, Jul 19
- Drop not useful TARGET writability test
- Discard header from template (both from new install and compat import of existing motd)
- Explicitly set template file permission when created from legacy motd
- Simplify replacing preexisting non-symlink /etc/motd
- Correct writability test for generated TARGET
- Simplify construction of /var/run/motd from template with header discarded
Sorry about the delay! I've been traveling and not very available. Thanks for the feedback, I will try to address it now.
Thu, Jul 18
Tue, Jul 16
Mon, Jul 15
I'd just drop the extra * on the other of the definition/declaration, but I don't know if we have a style(9) preference. Functionally / semantically it looks good.
Tue, Jul 9
The general idea of the change looks good to me, thanks!
FWIW, I also work on an embedded appliance.
Mon, Jul 8
I would change the commit summary/title, though. Really we're just disabling a feature when it is unsupported by some particular configuration; it's not bhyve-specific.
Sun, Jul 7
Looks good to me.
Sat, Jul 6
Wed, Jul 3
LGTM. For future reference, please upload patches with more context. That could mean using the arc command line tool, which simplifies the process somewhat once it is set up, or diff -U99999 if you prefer not to use the arc ("Arcanist") tool.
Fri, Jun 28
Thu, Jun 27
Wed, Jun 26
The design seems kind of poor (random last 32k corruption?). Alternatively / relatedly, we (ISLN) have a syslogd patch we can share that parses newsyslogd.conf and manually invokes newsyslogd directly when logs grow beyond configured rotation size.
Tue, Jun 25
Mon, Jun 24
Fri, Jun 21
- Fix a typo in rc.d/motd
- Update login(1) and motd.5
Jun 21 2019
Jun 20 2019
Need to change fifofs to actually use f_pipegen instead of f_seqcount :)
Rebase on recent HEAD
Also: nice find! :)
Looks like you could get a similar overflow by having 64k readers on a pipe too (fs/fifofs/fifo_vnops.c). You could also overflow in sequential_heuristic() if uio_resid is big enough (especially with a narrower f_seqcount).
Adding Kirk for UFS change.
Ah, I was thinking of FIEMAP I think. So the better question might be, why not add FIEMAP instead? https://www.kernel.org/doc/Documentation/filesystems/fiemap.txt
The name, etc, beg the question: what's the motivation to differ from FIOBMAP in Linux (or NetBSD)?
Jun 19 2019
As mjg@ points out, the mktemp file may be on a different filesystem than /etc
(e.g., tmpfs, but any other filesystem invalidates the initial fsync). Copy to
a temporary /etc file, sync that, then rename over /etc/motd.
Jun 18 2019
Jun 17 2019
Rename uint128_add to the more appropriate uint128_add64
As a first-cut workaround, LGTM.
Jun 15 2019
(<sys/param.h> includes <sys/types.h>; do not include both.)
Jun 14 2019
Jun 13 2019
Jun 10 2019
(bump .Dd if needed)
Thanks for splitting up the pages.
Jun 9 2019
Jun 8 2019
Jun 7 2019
Rebase on D20312 changes
@delphij , this one technically touches sys/dev/random (fix a declaration name typo but mostly add #ifndef _KERNEL compatibility shims), so I need secteam blessing to commit. I'd appreciate a look when you get a chance.
- Drop DELAY() entirely
- Minor optimization: drop global lock over 1-15 bytes of memcpy and 16 bytes explicit_bzero.