- Use a cast to sign extend the comparison value.
I've merged all changes to my patch but feel free to commit either one.
I have recently looked at this function to port adapt it for ZoF. I like the overall idea here, but as a nit please do try matching the surrounding style. I would also find it easier to follow without the extra negations. Calling the bool skip_zvols would read more naturally to me.
Updated patches after tests with llvm90 as base compiler.