Identifying some functionality all architectures have and trying to
make a common interface.
Squash review:
intrcompat: add "interrupt_t" typedef for all architectures
For code which doesn't care about the underlying structure and simply
needs to have a common name.
intrng: add standard interrupt controller interface
Interrupt numbering belongs to the interrupt controller, not the core
event code. As such, this layer should be providing a function to
resolve the interrupt number to the source/event.
powerpc: add ability to access intr_event by interrupt number
Most other systems have this via INTRNG or other means. Now add the
functionality to PowerPC.
intr/x86: implement standard interrupt interface
Different name for the main function, but then a simple macro on top.