I do not object against the idea of making more guts of kern_umtx.c usable for e.g. Linuxolator, but I think that polluting sys/umtx.h is not a right approach. I suggest to follow established practice, and add a new header, e.g. sys/umtxvar.h, where most of the stuff you moved could land.
More, I think that ideally you would move all the #ifdef _KERNEL bits from umtx.h to umtxvar.h, leaving umtx.h as ABI header for userspace.
Does it make sense?
|187 ↗||(On Diff #92488)|
This is too generic name to expose in the reusable header. Please name it e.g. umtx_abs_timeout().