- User Since
- Jan 29 2016, 5:27 AM (252 w, 3 d)
Wed, Nov 25
Merge in comments for the KERNLOAD into one blob.
Updated, thanks @markj !
Eliminate KERNEL_PHYSICAL_BASE althogether, move #include <machine/vmparam.h> into i386/amd64-specific section.
Tue, Nov 24
Sep 24 2020
Sep 23 2020
Thanks Ravi for suggestion, it has been incorporated.
Clarify intended use case for the new option.
Thank for a review Mark! 4 out of 5 suggestions have been incorporated, please check.
o (void)xyz -> xyz __unused;
Reset do_log_reopen earlier, so that we don't stuck in a loop calling this function repeatedly if error happens.
Use signal handler in a safe way.
Aug 24 2020
Apr 7 2020
Mar 26 2020
@imp any chance you can review and see if the change can land or indicate what other changes are necessary. Thanks!
Feb 18 2020
@imp the requested changes have been applied. Please check. Thanks!
Collapse .if/.else/.endif into one liner.
Oct 22 2019
Might need ("partial?") MFC into stable/11 stable/12.
Oct 21 2019
Jul 22 2019
Jul 1 2019
Document usage scenario bit further. Fix some mandoc formattings nits. Suggested by @mckusick
I will keep it at reviews for 1 week and then it will land unless major objections are received. Thanks!
Hey @imp can you please review the latest revision and confirm that it looks OK now?
Jun 5 2019
Rename MTREE -> DISTR_MTREE for clarity and in hope to make @rgrimes happier.
src.bootools.mk -> src.tools.mk as suggested by @imp
Looks good, as long as it compiles.
Jun 3 2019
Jun 2 2019
May 22 2019
Apr 10 2019
Mar 28 2019
Looks good to my VFS-naive eye. Thanks!
Mar 27 2019
Overall looks like a good start, however there are some things that I personally dislike:
Mar 26 2019
Not sure why this is still open. @mizhka_gmail.com please GC?
Check read-only flag in an unified manner.
Mar 22 2019
Feb 25 2019
Document "update" option, as suggested by @mckusick
Feb 23 2019
Feb 22 2019
Feb 21 2019
Also "device xz" needs to be added to the conf/NOTES.
Looks good overall. I am little bit puzzled over usage of "option GEOM_UZIP" vs. "device geom_uzip + device xz". I suspect those are functionally equivalent. Half of the kernel configs in the tree use former (including NOTES) and half the latter. Some subset of the two use both. :( Since you are touching those files anyways, perhaps you can go and convert all cases of "device geom_uzip" into plain "option GEOM_UZIP" and not patch it up by adding device xz? It might be also a good idea to adjust geom_uzip(4) accordingly to provide "One-True-Way" to compile geom_uzip(4) statically into the kernel? Thanks!
Jan 17 2019
Keep clist array in the args.c sorted by the name so that bsearch() DTRT.