Page MenuHomeFreeBSD

kfv (Faraz Vahedi)
User

Projects

User Details

User Since
Jun 14 2019, 6:43 AM (381 w, 1 d)

Recent Activity

Yesterday

kfv committed rG40f4174d62aa: jail(8): Preserve const qualifier on strchr(3) results (authored by kfv).
jail(8): Preserve const qualifier on strchr(3) results
Sat, Oct 3, 3:24 PM
kfv committed rGad60cb1085bc: pkg(7): Preserve const qualifier on strrchr(3) results (authored by kfv).
pkg(7): Preserve const qualifier on strrchr(3) results
Sat, Oct 3, 3:24 PM
kfv committed rG3b8ba87af29e: ls(1): Preserve const qualifier on strstr(3) result (authored by kfv).
ls(1): Preserve const qualifier on strstr(3) result
Sat, Oct 3, 3:24 PM
kfv committed rGa8fcc5892920: ed(1): Preserve const qualifier on strchr(3) result (authored by kfv).
ed(1): Preserve const qualifier on strchr(3) result
Sat, Oct 3, 3:24 PM
kfv committed rG850a848197b2: dd(1): Preserve const qualifier on bsearch(3) results (authored by kfv).
dd(1): Preserve const qualifier on bsearch(3) results
Sat, Oct 3, 3:24 PM
kfv committed rG536b344c40e2: devmatch(8): Preserve const qualifier on strchr(3) and strstr(3) results (authored by kfv).
devmatch(8): Preserve const qualifier on strchr(3) and strstr(3) results
Sat, Oct 3, 3:23 PM
kfv committed rG9c184546d062: ps(1): Preserve const qualifier on strchr(3) result (authored by kfv).
ps(1): Preserve const qualifier on strchr(3) result
Sat, Oct 3, 3:23 PM
kfv committed rG64df13dae7fc: libjail: Preserve const qualifier on strchr(3) and strrchr(3) results (authored by kfv).
libjail: Preserve const qualifier on strchr(3) and strrchr(3) results
Sat, Oct 3, 3:23 PM
kfv committed rG765615997a3a: virtio_console: Handle VIRTIO_CONSOLE_RESIZE (authored by kfv).
virtio_console: Handle VIRTIO_CONSOLE_RESIZE
Sat, Oct 3, 12:42 PM
kfv committed rG15198bfd7437: virtio: Validate host-supplied used lengths (authored by kfv).
virtio: Validate host-supplied used lengths
Sat, Oct 3, 12:42 PM
kfv committed rG9c8dcc2f2fbc: virtio_console: Negotiate VIRTIO_CONSOLE_F_SIZE (authored by kfv).
virtio_console: Negotiate VIRTIO_CONSOLE_F_SIZE
Sat, Oct 3, 12:42 PM
kfv closed D60094: virtio_console: Handle VIRTIO_CONSOLE_RESIZE.
Sat, Oct 3, 12:42 PM
kfv closed D60092: virtio: Validate host-supplied used lengths.
Sat, Oct 3, 12:42 PM
kfv closed D60089: virtio_console: Negotiate VIRTIO_CONSOLE_F_SIZE.
Sat, Oct 3, 12:42 PM
kfv updated the summary of D60094: virtio_console: Handle VIRTIO_CONSOLE_RESIZE.
Sat, Oct 3, 12:34 PM
kfv updated the summary of D60094: virtio_console: Handle VIRTIO_CONSOLE_RESIZE.
Sat, Oct 3, 12:33 PM

Wed, Sep 30

kfv retitled D60094: virtio_console: Handle VIRTIO_CONSOLE_RESIZE from virtio: Handle VIRTIO_CONSOLE_RESIZE to virtio_console: Handle VIRTIO_CONSOLE_RESIZE.
Wed, Sep 30, 9:13 AM
kfv retitled D60089: virtio_console: Negotiate VIRTIO_CONSOLE_F_SIZE from virtio: Negotiate VIRTIO_CONSOLE_F_SIZE to virtio_console: Negotiate VIRTIO_CONSOLE_F_SIZE.
Wed, Sep 30, 9:13 AM
kfv retitled D60092: virtio: Validate host-supplied used lengths from virtio: Clamp host-supplied used lengths to virtio: Validate host-supplied used lengths.
Wed, Sep 30, 9:12 AM
kfv updated the diff for D60092: virtio: Validate host-supplied used lengths.

Take care of the similar case in vtnet as well

Wed, Sep 30, 9:11 AM

Tue, Sep 29

kfv added a comment to D60094: virtio_console: Handle VIRTIO_CONSOLE_RESIZE.

Makes sense, right. I'll take care of it shortly. Thanks!

Tue, Sep 29, 10:33 PM
kfv added a comment to D60092: virtio: Validate host-supplied used lengths.

Sure thing. I actually wanted to keep this separate since this one is basically just a clamp while the other one in vtnet is IMHO more of a logical and policy change (and I needed to test that even further, to be honest). But since both are addressing the same concern (namely, not trusting the host to stay within the buffer) it could indeed make sense to have them both done here. I’ll take care of it tomorrow.

Tue, Sep 29, 10:31 PM

Mon, Sep 28

kfv requested review of D60094: virtio_console: Handle VIRTIO_CONSOLE_RESIZE.
Mon, Sep 28, 12:21 PM
kfv requested review of D60092: virtio: Validate host-supplied used lengths.
Mon, Sep 28, 11:27 AM
kfv requested review of D60089: virtio_console: Negotiate VIRTIO_CONSOLE_F_SIZE.
Mon, Sep 28, 10:41 AM

Fri, Sep 25

kfv accepted D59924: sysconf: accept a unique prefix of a target keyword.

Looks good to me, thanks!

Fri, Sep 25, 11:35 AM
kfv accepted D59943: sysconf: add a poudriere target.

Looks great. Thanks, Devin!

Fri, Sep 25, 11:33 AM

Tue, Sep 22

kfv committed rGab636e421d31: jail(8): Preserve const qualifier on strchr(3) results (authored by kfv).
jail(8): Preserve const qualifier on strchr(3) results
Tue, Sep 22, 7:07 PM
kfv closed D59876: jail(8): Preserve const qualifier on strchr(3) results.
Tue, Sep 22, 7:07 PM
kfv committed rG57d542cc92dc: libc: Preserve const qualifier on bsearch(3) results in tests (authored by kfv).
libc: Preserve const qualifier on bsearch(3) results in tests
Tue, Sep 22, 7:02 PM
kfv committed rG91973f51fc6a: libc: Implement bsearch_s(), document bsearch_b(), and add unit tests (authored by kfv).
libc: Implement bsearch_s(), document bsearch_b(), and add unit tests
Tue, Sep 22, 7:02 PM
kfv committed rGb169b80d409c: libc: Parenthesise qualifier-preserving function definitions (authored by kfv).
libc: Parenthesise qualifier-preserving function definitions
Tue, Sep 22, 7:02 PM
kfv committed rGf12021302954: libc: Use C23 pseudo-types in qualifier-preserving man page synopses (authored by kfv).
libc: Use C23 pseudo-types in qualifier-preserving man page synopses
Tue, Sep 22, 7:02 PM
kfv committed rG4bdbd68e6b76: libc: Implement qualifier-preserving standard library functions (authored by kfv).
libc: Implement qualifier-preserving standard library functions
Tue, Sep 22, 7:02 PM

Mon, Sep 21

kfv requested review of D59876: jail(8): Preserve const qualifier on strchr(3) results.
Mon, Sep 21, 4:30 PM

Sat, Sep 19

kfv committed rG47f9e6650782: pkg(7): Preserve const qualifier on strrchr(3) results (authored by kfv).
pkg(7): Preserve const qualifier on strrchr(3) results
Sat, Sep 19, 10:19 AM
kfv committed rGcc61cc7b638a: ls(1): Preserve const qualifier on strstr(3) result (authored by kfv).
ls(1): Preserve const qualifier on strstr(3) result
Sat, Sep 19, 10:19 AM
kfv committed rG066fad8aefcb: ed(1): Preserve const qualifier on strchr(3) result (authored by kfv).
ed(1): Preserve const qualifier on strchr(3) result
Sat, Sep 19, 10:19 AM
kfv committed rG225612c76d87: dd(1): Preserve const qualifier on bsearch(3) results (authored by kfv).
dd(1): Preserve const qualifier on bsearch(3) results
Sat, Sep 19, 10:19 AM
kfv closed D59777: pkg(7): Preserve const qualifier on strrchr(3) results.
Sat, Sep 19, 10:19 AM
kfv closed D59774: ls(1): Preserve const qualifier on strstr(3) result.
Sat, Sep 19, 10:18 AM
kfv closed D59773: ed(1): Preserve const qualifier on strchr(3) result.
Sat, Sep 19, 10:18 AM
kfv closed D59754: dd(1): Preserve const qualifier on bsearch(3) results.
Sat, Sep 19, 10:18 AM

Thu, Sep 17

kfv requested review of D59777: pkg(7): Preserve const qualifier on strrchr(3) results.
Thu, Sep 17, 11:59 PM
kfv requested review of D59774: ls(1): Preserve const qualifier on strstr(3) result.
Thu, Sep 17, 8:59 PM
kfv requested review of D59773: ed(1): Preserve const qualifier on strchr(3) result.
Thu, Sep 17, 8:42 PM
kfv accepted D59746: sysconf: Remove visual line-break after .Dd in man-pages (ziaee).
Thu, Sep 17, 3:45 PM
kfv accepted D59747: RELNOTES: Add an entry for sysconf(8) and libbsdconf(3).
Thu, Sep 17, 12:10 PM
kfv requested review of D59754: dd(1): Preserve const qualifier on bsearch(3) results.
Thu, Sep 17, 5:09 AM

Wed, Sep 16

kfv accepted D58066: Add sysconf(8) and libbsdconf(3).
Wed, Sep 16, 6:38 PM
kfv accepted D59720: libbsdconf: independent version macros.
Wed, Sep 16, 11:41 AM

Tue, Sep 15

kfv closed D59666: ps(1): Preserve const qualifier on strchr(3) result.
Tue, Sep 15, 4:19 PM
kfv closed D59667: devmatch(8): Preserve const qualifier on strchr(3) and strstr(3) results.
Tue, Sep 15, 4:19 PM
kfv committed rGd10e39d489a6: ps(1): Preserve const qualifier on strchr(3) result (authored by kfv).
ps(1): Preserve const qualifier on strchr(3) result
Tue, Sep 15, 4:19 PM
kfv committed rG592ae60e2b2e: devmatch(8): Preserve const qualifier on strchr(3) and strstr(3) results (authored by kfv).
devmatch(8): Preserve const qualifier on strchr(3) and strstr(3) results
Tue, Sep 15, 4:19 PM

Mon, Sep 14

kfv requested review of D59667: devmatch(8): Preserve const qualifier on strchr(3) and strstr(3) results.
Mon, Sep 14, 2:09 PM
kfv requested review of D59666: ps(1): Preserve const qualifier on strchr(3) result.
Mon, Sep 14, 1:55 PM

Sun, Sep 13

kfv committed rG73d3c964be93: libc: Preserve const qualifier on strchr(3), strrchr(3), and memchr(3) results (authored by kfv).
libc: Preserve const qualifier on strchr(3), strrchr(3), and memchr(3) results
Sun, Sep 13, 12:34 PM
kfv committed rG3caa8d2c58b2: libc: Preserve const qualifier on bsearch(3) results in tests (authored by kfv).
libc: Preserve const qualifier on bsearch(3) results in tests
Sun, Sep 13, 12:33 PM
kfv committed rGc389738f21c0: libc: Parenthesise qualifier-preserving function definitions (authored by kfv).
libc: Parenthesise qualifier-preserving function definitions
Sun, Sep 13, 12:33 PM
kfv closed D59612: libc: Preserve const qualifier on strchr(3), strrchr(3), and memchr(3) results.
Sun, Sep 13, 12:33 PM
kfv closed D59600: libc: Parenthesise qualifier-preserving function definitions.
Sun, Sep 13, 12:33 PM
kfv closed D59611: libc: Preserve const qualifier on bsearch(3) results in tests.
Sun, Sep 13, 12:33 PM

Sat, Sep 12

kfv accepted D56637: dhclient(8): Add support for IPv6-Only option (RFC 8925).

Looks good to me now. Thanks!

Sat, Sep 12, 4:25 PM
kfv accepted D59589: website: Restore "The Power to Serve" on homepage.
Sat, Sep 12, 3:02 PM
kfv requested review of D59612: libc: Preserve const qualifier on strchr(3), strrchr(3), and memchr(3) results.
Sat, Sep 12, 11:43 AM
kfv requested review of D59611: libc: Preserve const qualifier on bsearch(3) results in tests.
Sat, Sep 12, 11:26 AM
kfv added a comment to D59600: libc: Parenthesise qualifier-preserving function definitions.

I wasn't planning to include a description in the commit body, but perhaps a brief explanation like the one above would be useful?

Sat, Sep 12, 10:12 AM
kfv added a comment to D59600: libc: Parenthesise qualifier-preserving function definitions.

This is required to prevent function-like macros with the same name from being expanded in the definitions once they become active in a later C mode. Without the parentheses, the declarator is rewritten and will not compile. This style is used for similar cases such as mempcpy() too.

Sat, Sep 12, 10:08 AM
kfv added a comment to D56637: dhclient(8): Add support for IPv6-Only option (RFC 8925).

Diff 7/8 looks good on the INIT-REBOOT RELEASE/disassoc path, but ignore ipv6only doesn't seem to be a real opt-out.

Sat, Sep 12, 1:06 AM

Fri, Sep 11

kfv requested review of D59600: libc: Parenthesise qualifier-preserving function definitions.
Fri, Sep 11, 9:40 PM

Thu, Sep 10

kfv accepted D56637: dhclient(8): Add support for IPv6-Only option (RFC 8925).

Same here, I’ve been testing it for a while now, and it has my approval as well. Thanks a lot for all the effort, Pouria!

Thu, Sep 10, 5:38 PM
kfv committed rGc63b69f82a74: libjail: Preserve const qualifier on strchr(3) and strrchr(3) results (authored by kfv).
libjail: Preserve const qualifier on strchr(3) and strrchr(3) results
Thu, Sep 10, 11:10 AM
kfv closed D59553: libjail: Preserve const qualifier on strchr(3) and strrchr(3) results.
Thu, Sep 10, 11:10 AM
kfv requested review of D59553: libjail: Preserve const qualifier on strchr(3) and strrchr(3) results.
Thu, Sep 10, 12:00 AM

Tue, Sep 8

kfv updated the diff for D59213: libc: Implement mbrtoc8() and c8rtomb() as per C23.

Drop sizeof(mbstate_t) - sizeof(_Char8State) >= 64 for now

Tue, Sep 8, 9:18 PM
kfv added inline comments to D59213: libc: Implement mbrtoc8() and c8rtomb() as per C23.
Tue, Sep 8, 9:16 PM
kfv added a comment to D59213: libc: Implement mbrtoc8() and c8rtomb() as per C23.

Mark review comment on _Mbrtoc8Extra as done, as it is no longer applicable following the changes that were implemented.

Tue, Sep 8, 8:52 PM
kfv updated the diff for D59213: libc: Implement mbrtoc8() and c8rtomb() as per C23.

Rename _C8rtombExtra to _Char8State for consistency

Tue, Sep 8, 8:45 PM
kfv added a comment to D59213: libc: Implement mbrtoc8() and c8rtomb() as per C23.

Mark several review notes as resolved: Björn Höhrmann’s DFA implementation, __cpp_char8_t rationale, u8'\0' clarification, c8rtomb licensing, data type improvements, the states enum, urtf8d table formatting, and unit test improvements.

Tue, Sep 8, 6:38 PM
kfv added a comment to D59213: libc: Implement mbrtoc8() and c8rtomb() as per C23.

Thanks for your notes! Sure, I’ll keep them in mind and take care of those herein in a minute.

Tue, Sep 8, 6:13 PM
kfv updated the diff for D59213: libc: Implement mbrtoc8() and c8rtomb() as per C23.

Address the remaining review points

Tue, Sep 8, 11:25 AM
kfv added inline comments to D59213: libc: Implement mbrtoc8() and c8rtomb() as per C23.
Tue, Sep 8, 11:22 AM
kfv added inline comments to D59213: libc: Implement mbrtoc8() and c8rtomb() as per C23.
Tue, Sep 8, 11:09 AM
kfv accepted D59462: lib/msun amd64: use AVX FMA instructions for fma(3) and fmaf(3) when available.
Tue, Sep 8, 9:13 AM
kfv updated the diff for D59213: libc: Implement mbrtoc8() and c8rtomb() as per C23.

Address the three promised review points

Tue, Sep 8, 8:19 AM
kfv added a comment to D59213: libc: Implement mbrtoc8() and c8rtomb() as per C23.

Sorry if I made some modifications to what you sent me via email. I actually thought I was allowed to, as it isn't finalised yet and we're working through it together. I'm just trying to make sure we're not rushing things and that we're on the same page as we go along, for future maintenance and stuff we'd be working on together. I certainly don't mean to be rude or inattentive. Also, thank you for putting so much time and effort into reviewing everything, explaining things, and discussing it all with me, and being this much receptive and kind throughout. I really appreciate it.

Tue, Sep 8, 7:58 AM

Mon, Sep 7

kfv accepted D59474: jib, jng: Move to usr.sbin and add manuals.

Nice move. Thanks!

Mon, Sep 7, 7:25 PM · Netgraph
kfv updated the diff for D59213: libc: Implement mbrtoc8() and c8rtomb() as per C23.

Default MK_ICONV=yes now runs mbrtoc8/c8rtomb through Citrus like c16/c32, and unsurprisingly, we now inherit its bugs as a result: null s resets, ill-formed input often comes back as (size_t)-2, 5-/6-byte UTF-8 (as with RFC 2279 §2—obsoleted by RFC 3629 §3) and values above U+10FFFF are accepted, U+FEFF fails, and each mbstate_t leaks. Those need an iconv fix, though, so not c8 special cases. FWIW, WITHOUT_ICONV c8rtomb stays C23 in (c8rtomb.c / mbrtoc8.c), and mbrtoc8 matches mbrtoc16.

Mon, Sep 7, 4:27 PM

Sun, Sep 6

kfv accepted D59462: lib/msun amd64: use AVX FMA instructions for fma(3) and fmaf(3) when available.

Brilliant work. Thanks!

Sun, Sep 6, 8:33 PM
kfv committed rGf66c8680e804: look(1): Capsicumise (authored by kfv).
look(1): Capsicumise
Sun, Sep 6, 7:51 AM

Sat, Sep 5

kfv committed rG72ed6f9c9dc9: libc: Add WCHAR_WIDTH in <wchar.h> as well (authored by kfv).
libc: Add WCHAR_WIDTH in <wchar.h> as well
Sat, Sep 5, 10:49 AM
kfv closed D59385: libc: Add WCHAR_WIDTH in <wchar.h> as well.
Sat, Sep 5, 10:49 AM
kfv updated the summary of D59385: libc: Add WCHAR_WIDTH in <wchar.h> as well.
Sat, Sep 5, 10:44 AM
kfv committed rG733ea4ee584d: libc: Add <inttypes.h> C23 feature test macro (authored by kfv).
libc: Add <inttypes.h> C23 feature test macro
Sat, Sep 5, 8:32 AM
kfv closed D59382: libc: Add <inttypes.h> C23 feature test macro.
Sat, Sep 5, 8:31 AM
kfv added a comment to D59382: libc: Add <inttypes.h> C23 feature test macro.

Thanks, Robert! Sure, I will do.

Sat, Sep 5, 8:25 AM

Fri, Sep 4

kfv updated the diff for D59385: libc: Add WCHAR_WIDTH in <wchar.h> as well.

Move __WCHAR_WIDTH into sys/sys/_types.h

Fri, Sep 4, 1:01 PM
kfv added a comment to D59385: libc: Add WCHAR_WIDTH in <wchar.h> as well.

If the size is the same on all platforms, it should not be in the platform-specific _types.h files.

Fri, Sep 4, 12:50 PM
kfv requested review of D59385: libc: Add WCHAR_WIDTH in <wchar.h> as well.
Fri, Sep 4, 9:59 AM