- User Since
- Nov 13 2017, 4:43 AM (87 w, 6 d)
Mon, Jul 15
Actually, this file rename doesn't fix https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=205822.
I don't think it is worth addressing this bug report here as removing the zlib in zfs also fixes this issue and we are aiming for this serious of changes.
Sat, Jul 13
Disable broken gzipped aout executable support and rename zlib in ZFS to avoid filename conflicts.
Thu, Jul 11
D20635 picked up the changes.
Tue, Jul 9
Adjusted sys/type.h include to FreeBSD section and also moved crypto_z* function implementations to top of file.
Sun, Jul 7
Drop NO_GZIP compile option changes in zlib as these aren't necessary at this stage.
I had missed zcalloc.c in sys/modules/Makefile, too.
Missed zcallc.h/c files from last update.
Drop -DMY_ZCALLOC from kmod.mk but put zcfree() back.
Fri, Jul 5
Drop -DMY_ZCALLOC as no use under -DZ_SOLO.
Use -DZ_SOLO to avoid standard C header files.
ZFS requires Non-Z_SOLO ZLIB and we will revisit when we work on ZFS.
Combined opencrypto conversion to avoid dtrace probe name changes.
Wed, Jul 3
I've been away and haven't been able to follow up or read updates on any of "swapoff" related changes for the last one week.
I won't be able to get back to this for another week; I will find the situations and figure out what to do later.
It is currently looking like Doug is finalizing changes based at quick look of incoming email titles. I appreciate your passion.
Thu, Jun 27
Added sys/contrib/zlib/crc32.c to zlib kernel module.
Drop underscore from symbols - changed prefix from _zlib104 to zlib104.
Jun 21 2019
Removed commented code in Makefiles.
Jun 19 2019
crc32 split has been comitted and code rebased.
Xin committed this change with minor adjustments and https://svnweb.freebsd.org/base?view=revision&revision=349151 was the revision.
Jun 18 2019
Jun 17 2019
Jun 15 2019
Pick up Doug's patch for searcing multiple blocks and split code check-in mergess.
Jun 14 2019
Doung, thank you for your very prompt responses. I looked into more after kib concerned locks and Alan's comment. I think they are right and this code has issues. Indeed, swp_pager_meta_ctl() calls are very expensive. I also experience few other issues and trying to figure out. For example, I use VMWare on Mac for this testing these days compare to when I used physical machines when I originally made this change; VMWare stalls at high memory utilization and heavy host I/O. I will be traveling shortly, too.
https://svnweb.freebsd.org/ports?view=revision&revision=504002 removed from the port tree per https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=21519#c15
Jun 12 2019
Jun 7 2019
Move vm_object_pip_wakeup() and vm_pager_page_unswapped() back to swp_pager_force_pagein().
Change -= SWAP_META_PAGES to %= SWAP_META_PAGES.
Jun 6 2019
Revert back some changes.
I don't think swp_pager_find_continuous() was a good idea/implementation. I will revert it shortly.
Jun 5 2019
Thank you for taking a look.
Created swp_pager_find_continuous instead of calling swap_pager_haspage().
Jun 4 2019
Doug, thank you for elaboration.
Let's see how that approach works this time.
When I started and tried, it wasn't as easy and I decided to take advantages of existing functions.
Resolve conflicts, fix style, and break a function.
Jun 1 2019
May 31 2019
Exp-run info: https://www.freebsd.org/doc/en/articles/committers-guide/ports.html#ports-exp-run
For example https://bugs.freebsd.org/214864 is the exp-run I requested for lld.
I agree that there shouldn't be any ports using sys/dir.h still but it is still good to confirm that prior to the commit. (Here it's almost certainly been long enough that it's not necessary, but is a best practice.)
I'll ask in the #bsdports channel if anyone there thinks it's necessary.
I updated test case section with performance measurement.
What do you mean by "an exp-run?" I had made buildworld and buildkernel successful on i386. Universe will be better but I don't have enough disk space.
May 30 2019
May 29 2019
Fix KERN to GSB.
After research, I found that our crc32 functions are based on the code written
by Gary S Brown. We also have many other *crc32.[hc] files, too. Rather than,
prefixing with kern, prefix with his initial to honor his work.
It looks kern prefix is used for sub-systems.
May 25 2019
May 24 2019
Reverted few of experiments back to a working code.
This also crashed.
Also experimented without calling swap_pager_haspage().
The result was instant reboot.
I will revert and fix KASSERTs.
I will also test removing swap_pager_haspage() call.
Moved i -= SWAP_META_PAGES decrement and update variables to print in KASSERT.
May 23 2019
Thank you for review comments.
Given loops changed a lot, I'd like to send more time testing the recent changes.
I also want to update some comments in the code to be more descriptive and clear.
Simplify the swp_blks loop and adjust style.
May 22 2019
Delete an extra empty line.
It is boolean_t type and thus check TRUE instead of true.
Take return value of vm_pager_has_page() as boolean instead of int.
Adjusted baesd on review comments for function names and nested loop to a loop.
I didn't realize I had had comments on this.
I sincerely apologize.
Doug have made lots of improvements in this area and I'm not sure if this patch/changeset applies to the latest code base.
I will take a look.
May 20 2019
Svn up and resolved conflicts.
r347984 creates conflicts for lio_bsd.h and if_cdce.c.
I need to svn up and rebase.
May 17 2019
More _KERNEL adjustments.
Remove one more extra prototype.
Replace ifdef USERSPACE_TESTING to ifndef _KERNEL.
May 16 2019
May 15 2019
It looks this change hasn't yet committed.
Delete unneeded comments and put 2019 May.
May 14 2019
This change requires https://reviews.freebsd.org/D20193 to address duplicate crc32() API between zlib and libkern.h.
I will make some minor adjustments after that's done.
Don't touch ZFS module, yet.
I split the original change-set to multiple ones.
I was able to link both old and new versions of zlib at same time over weekend.
So, this change became no longer immediate blocker.
I thought it would be nicer to address zlib conversion in a single commit instead of two commits once upon time.
Exclude unintended files... :(
Delete comments about usage of STD_PROBE5.
May 13 2019
It looks I can put 2 versions of zlib into kernel.
Let's wait and see.
May 12 2019
Rename libkern/crc32.c to libkern/kern_crc32.c to avoid having same object
filename as zlib/crc32.c.
I'd like to rename libkern/crc32.c to libkern/kern_crc32.c so that we don't get object filename conflict with zlib/crc32.c as well.
I'm having difficulties with arc diff...