Page MenuHomeFreeBSD

arm64: Rename pmap_kenter() to pmap_kenter_arm64()
AbandonedPublic

Authored by ehem_freebsd_m5p.com on Feb 21 2021, 1:59 AM.
Tags
None
Referenced Files
Unknown Object (File)
Mon, Aug 25, 3:27 AM
Unknown Object (File)
Wed, Aug 13, 9:10 AM
Unknown Object (File)
Sun, Aug 3, 12:11 AM
Unknown Object (File)
Sat, Aug 2, 7:46 PM
Unknown Object (File)
Fri, Aug 1, 2:27 AM
Unknown Object (File)
Jul 29 2025, 4:06 AM
Unknown Object (File)
Jul 28 2025, 2:40 PM
Unknown Object (File)
Jul 27 2025, 5:00 PM

Details

Reviewers
manu
mhorne
Group Reviewers
arm64
Summary

Many architectures have pmap_kenter(vm_offset_t va, vm_paddr_t pa). As
such having a 4-argument pmap_kenter() function on arm64 serves to
confuse and make multi-arch code harder. Given this, rename arm64's
pmap_kenter() function to pmap_kenter_arm64*).

During rename replace use of "pmap_kenter" inside strings with use of
func. Hopefully this helps preserve the sanity of and avoid errors
by future authors.

Diff Detail

Repository
rS FreeBSD src repository - subversion
Lint
Lint Passed
Unit
No Test Coverage
Build Status
Buildable 37394
Build 34283: arc lint + arc unit

Event Timeline

This was a distinct annoyance of this function of the same name, but distinct signature getting in the way while trying to finish other bits. Luckily this isn't urgent as what I was fighting got solved, but this was distinctly annoying.

Updating since D28890 took out one of the hunks (a Good Thing(tm))

I still think the renaming is appropriate, but since the crucial spot has been resolved by other means I'll simply drop this.