Page MenuHomeFreeBSD

pmap_mapdev: Consistently use vm_paddr_t for the first argument.
ClosedPublic

Authored by jhb on Tue, Jul 26, 10:37 PM.

Details

Summary

The devmap variants used vm_offset_t for some reason, and a few places
explicitly cast bus addresses to vm_offset_t. (Probably those casts
along with similar casts for vm_size_t should just be removed and
instead permit the compiler to DTRT.)

Sponsored by: DARPA

Diff Detail

Repository
rG FreeBSD src repository
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.

Event Timeline

jhb requested review of this revision.Tue, Jul 26, 10:37 PM
This revision is now accepted and ready to land.Wed, Jul 27, 3:19 PM
sys/kern/subr_devmap.c
273

This can probably be reverted back to trunc_page? I think I was just overly cautious.

293

It might be a nice followup if pmap_mapdev() on aarch64 and risc-v just called pmap_mapdev_attr() so we could avoid code duplication.

sys/kern/subr_devmap.c
273

I can't see any reason not to use trunc_page() with a vm_paddr_t...