Page MenuHomeFreeBSD

riscv: add COMPAT_FREEBSD{12,13} options
ClosedPublic

Authored by kp on Nov 16 2021, 8:52 PM.

Details

Summary

Turn on compat options for older FreeBSD versions. We do not enable the
compat options for 11 or older because riscv was never supported in
those versions.

Sponsored by: Rubicon Communications, LLC ("Netgate")

Diff Detail

Repository
R10 FreeBSD src repository
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.

Event Timeline

kp requested review of this revision.Nov 16 2021, 8:52 PM
jrtc27 added a subscriber: jrtc27.

Noticed this in the past and never got round to doing anything about it. COMPAT_FREEBSD12 should also be MFC'ed.

This revision is now accepted and ready to land.Nov 17 2021, 12:44 AM

Noticed this in the past and never got round to doing anything about it. COMPAT_FREEBSD12 should also be MFC'ed.

Good point. I think I'll remove COMPAT_FREEBSD13 from this commit and add that to D33005 instead. That'll make MFC-ing easier.

This revision was automatically updated to reflect the committed changes.