Page MenuHomeFreeBSD

Mk/Uses/python.mk: prepare for python 3.10
ClosedPublic

Authored by AMDmi3 on Mar 25 2021, 12:47 AM.

Details

Summary

Python versions with 2-digit minor are not currently supported, so fix it in preparation for python 3.10.

Test Plan

Tested in poudriere with python 3.10 as default. Example build log:

https://people.freebsd.org/~amdmi3/py310-libversion.log

Diff Detail

Repository
rP FreeBSD ports repository
Lint
No Linters Available
Unit
No Unit Test Coverage
Build Status
Buildable 38541
Build 35430: arc lint + arc unit

Event Timeline

Fix min/max version calculation

This is incomplete, PYTHON_REL has to be changed to a 5 digits string too

Switch PYTHON_REL to 5 digits

  • Mk: switch PYTHON_REL to 5 digits to support python 3.10.x
  • Mk: add framework support for two digit python minor version

Rebased and updated to latest version split into 3 commits:

  • 5 digit PYTHON_REL
  • 2 digit minor support
  • switch from PYTHON_PORTVERSION to PYTHON_DISTVERSION