r273174 renames in-kernel version of getenv/setenv to kern_setenv/kern_getenv.
This commit updates the manpage accordingly.
Details
Diff Detail
- Lint
Lint Skipped - Unit
Tests Skipped
Event Timeline
The manpage changes are ok, but I'm not a huge fan of this change in general. You have kern_getenv(), but the rest of the functions are getenv*() so that is confusing. Also, there is a userland unsetenv(3), yet you didn't rename the kernel unsetenv(), so the change isn't complete either. :(
I would rather find another way to solve this problem if possible then obfuscating all of the kernel source code. sys_foo() was annoying but tolerable-ish, but this is much more annoying. These routines at least have very similar semantics (and getenv() has the same API/ABI). How are you handling malloc() and free()? Those seem like a much larger problem (and renaming those would also be far more invasive and something I would oppose).
unsetenv is not used anywhere in the kernel -- just in the loader. As you may see the loader code was unchanged.
Do you have an alternative to handle the whole thing in your mind?