Many architectures have pmap_kenter(vm_offset_t va, vm_paddr_t pa). As
such having a 4-argument pmap_kenter() function on arm64 serves to
confuse and make multi-arch code harder. Given this, rename arm64's
pmap_kenter() function to pmap_kenter_arm64*).
During rename replace use of "pmap_kenter" inside strings with use of
func. Hopefully this helps preserve the sanity of and avoid errors
by future authors.