Page MenuHomeFreeBSD

Replace all uses of kern_mmap with kern_mmap_req

Authored by brooks on Jan 23 2021, 12:25 AM.



The helper saved some code churn initially, but having multiple
interfaces is sub-optimal.

Remove the old kern_mmap.

Rename kern_mmap_req to kern_mmap

There is no need for the suffix now that there is only one interface.

Diff Detail

R10 FreeBSD src repository
Automatic diff as part of commit; lint not applicable.
Automatic diff as part of commit; unit tests not applicable.

Event Timeline

brooks created this revision.

I've done this cleanup in CheriBSD on the path to some local cleanups.

I've chosen to use compound literals because they are IMO tidier than single use temporary variables when the initialization values aren't available at the top of the file. They aren't widely used in the tree so now is probably the time to discuss style. The one aspect of the current style I debated the most was if the &(struct foo){ should be on it's own line or on the line above. I felt splitting it out worked well with the other indentation.

kib added inline comments.

I would fill the previous line by merging with this one.

This revision is now accepted and ready to land.Jan 23 2021, 11:43 AM
  • Rebase
  • Use a slightly more compact style
This revision now requires review to proceed.Jan 25 2021, 9:24 PM
This revision is now accepted and ready to land.Jan 25 2021, 9:49 PM
This revision was automatically updated to reflect the committed changes.