The helper saved some code churn initially, but having multiple
interfaces is sub-optimal.
Remove the old kern_mmap.
Rename kern_mmap_req to kern_mmap
There is no need for the suffix now that there is only one interface.
Differential D28292
Replace all uses of kern_mmap with kern_mmap_req brooks on Jan 23 2021, 12:25 AM. Authored by Tags None Referenced Files
Subscribers None
Details
The helper saved some code churn initially, but having multiple Remove the old kern_mmap. Rename kern_mmap_req to kern_mmap There is no need for the suffix now that there is only one interface.
Diff Detail
Event TimelineComment Actions I've done this cleanup in CheriBSD on the path to some local cleanups. I've chosen to use compound literals because they are IMO tidier than single use temporary variables when the initialization values aren't available at the top of the file. They aren't widely used in the tree so now is probably the time to discuss style. The one aspect of the current style I debated the most was if the &(struct foo){ should be on it's own line or on the line above. I felt splitting it out worked well with the other indentation.
|