Page MenuHomeFreeBSD

devstat(9): Rename devstat_add_entry to devstat_new_entry
ClosedPublic

Authored by gbe on Jul 15 2020, 7:33 AM.

Details

Summary

devstat(9): Rename devstat_add_entry to devstat_new_entry

  • Rename devstat_add_entry to devstat_new_entry
  • Update the description of devstat_trans_flags
  • Add manpage aliases for devstat_start_transaction_bio and devstat_end_transaction_bio

PR: 157316

Test Plan

mandoc output review, 'mandoc -Tlint checks"

Diff Detail

Repository
rS FreeBSD src repository
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.

Event Timeline

gbe requested review of this revision.Jul 15 2020, 7:33 AM
gbe created this revision.
bcr added a subscriber: bcr.

Approved (although I'm not so sure about the SCSI part, but I'll go with the spirit of the example given, not the actual technology used).

This revision is now accepted and ready to land.Jul 15 2020, 8:30 AM

Thanks! devstat_add_entry.9 should probably be added to ObsoleteFiles too?

share/man/man9/devstat.9
381–382 ↗(On Diff #74474)

I'm not sure we should be documenting struct devstat in manual pages at all; that said, we already do, so making it complete is good.

What does "identification for GEOM nodes" mean? It's also the comment in the code, but without looking at how the field is used, I have no idea what this means. So I'm not sure it's especially useful documentation.

  • Add devstat_add_entry.9 to ObsoleteFiles.inc
This revision now requires review to proceed.Jul 15 2020, 4:59 PM
This revision is now accepted and ready to land.Jul 15 2020, 5:01 PM
In D25677#568226, @cem wrote:

Thanks! devstat_add_entry.9 should probably be added to ObsoleteFiles too?

Thanks for the hint, I just added it to ObsoleteFiles.Inc.!

share/man/man9/devstat.9
381–382 ↗(On Diff #74474)

This is directly taken from the comment in the code, but I am not that deep into the code to provide a better explanation. I would leave it in the man page for the reason to fully describe the struct.

  • Use the correct path for devstat_add_entry.9 removal in ObsoleteFiles.inc
This revision now requires review to proceed.Jul 15 2020, 5:15 PM

Rename devstat_add_entry to devstat_new_entry -- but why?

Rename devstat_add_entry to devstat_new_entry -- but why?

The function was deleted from sys/sys/devicestat.h around 2003 and devstat_new_entry was added as a replacement.

In D25677#568288, @gbe wrote:

Rename devstat_add_entry to devstat_new_entry -- but why?

The function was deleted from sys/sys/devicestat.h around 2003 and devstat_new_entry was added as a replacement.

Ah! :-) Thanks!

This revision was not accepted when it landed; it landed in state Needs Review.Jul 17 2020, 10:15 PM
This revision was automatically updated to reflect the committed changes.