Use helper functions to reduce code duplication in merging vm_entry neighbors.
Details
Diff Detail
- Lint
Lint Skipped - Unit
Tests Skipped
Event Timeline
head/sys/vm/vm_map.c | ||
---|---|---|
1648 ↗ | (On Diff #49373) | This function does not by itself prove that two entries are mergeable. Hence, its name is misleading. It's necessary that, for example, the entry is not a submap or in transition. I would like to see those conditions asserted here. Alternatively, and contradicting my initial comment, giving this function a name like vm_map_simplify_test() would discourage the reuse of this function elsewhere, where the necessary conditions on eflags have not been established. |
1651 ↗ | (On Diff #49373) | Now that this code is deindented, this variable is pointless. It's is used once, and computing this value before we know that end == start and the objects match is wasted effort. |
1665 ↗ | (On Diff #49373) | vm_map_simplify_deallocate(). Historically, "dispose" functions were simple free operations. |
1669–1680 ↗ | (On Diff #49373) | Now that this comment is deindented, the text should be "reflowed". |
head/sys/vm/vm_map.c | ||
---|---|---|
1648 ↗ | (On Diff #49373) | I'll rename to vm_map_neighbor_test, since 'neighbor' is a term introduced in the comment that describes the 'simplify_entry' function, and 'simplify_test' sounds like we're simplifying some sort of test, which sounds pretty generic. |
1665 ↗ | (On Diff #49373) | vm_map_neighbor_deallocate(). |