According to POSIX 1003.1-2008, dsize should be size_t. Unfortunately this would break the ABI. Since size_t is unsigned, we can at least make it a unsigned so the types are more compatible and we avoid some implicit sign/unsigned casts.
According to opengrok, all uses involve assignments to/from unsigned variables so there would be no negative side-effects to this change..