Page MenuHomeFreeBSD

Rename PKG_CMD to PKG_REGISTER
ClosedPublic

Authored by bapt on Nov 30 2016, 10:18 AM.

Details

Summary

PKG_CMD is a legacy from the pkg_tools time, it is now defined in bsd.own.mk in
an incompatible way. Rename it PKG_REGISTER to avoid collision and have a
variable name more accurate

Diff Detail

Repository
rP FreeBSD ports repository
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.

Event Timeline

bapt retitled this revision from to Rename PKG_CMD to PKG_REGISTER.
bapt updated this object.
bapt edited the test plan for this revision. (Show Details)
bapt added a reviewer: portmgr.
Mk/bsd.port.mk
1807–1809 ↗(On Diff #22615)

What this intended ?

Mk/bsd.port.mk
1807–1809 ↗(On Diff #22615)

no I will make sure not to commit that :=)

swills added a reviewer: swills.
swills added a subscriber: swills.

Looks fine as long as you skip the part @mat pointed out.

This revision is now accepted and ready to land.Dec 1 2016, 6:13 PM
bdrewery edited edge metadata.
This revision was automatically updated to reflect the committed changes.