Page MenuHomeFreeBSD

Zopkio and Naarad.
ClosedPublic

Authored by araujo on Mar 18 2016, 6:05 AM.

Diff Detail

Repository
rP FreeBSD ports repository
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.

Event Timeline

araujo retitled this revision from to Zopkio and Naarad..
araujo updated this object.
araujo edited the test plan for this revision. (Show Details)

Also, both pkg-message files seems to be empty, and should, so, be removed too.

benchmarks/naarad/Makefile
23 ↗(On Diff #14415)

That's the default, it's not needed.

benchmarks/zopkio/Makefile
16–21 ↗(On Diff #14415)

Instead of setting WRKSRC, set GH_PROJECT to Zopkio.

16–21 ↗(On Diff #14415)

Or better, set PORTNAME to Zopkio.

math/py-luminol/Makefile
20 ↗(On Diff #14415)

default, please remove.

benchmarks/zopkio/Makefile
16–21 ↗(On Diff #14415)

The WRKSRC is necessary, because the GH_PROJECT overtake the value on PORTNAME, doesn't matter if I set the PORTNAME to Zopkio or zopkio, what is defined on GH_PROJECT will overtake on WRKSRC.

So, WRKSRC is necessary!

  • Remove those pkg-message files that were empty. (Part of my template)
  • Address @mat issues.

Add few dependencies missed for zopkio.

benchmarks/zopkio/Makefile
16–21 ↗(On Diff #14415)

No. If you set PORTNAME=Zopkio, you don't need to set GH_PROJECT, because it'll be ok, and then WRKSRC is not needed because it's already the right value.

This all looks good, I think, though, that, as they are python ports, they should be named foo/py-bar, and have PKGNAMEPREFIX=${PYTHON_PKGNAMEPREFIX}
But I'll let someone from Python have a say on that.

In D5670#121723, @mat wrote:

This all looks good, I think, though, that, as they are python ports, they should be named foo/py-bar, and have PKGNAMEPREFIX=${PYTHON_PKGNAMEPREFIX}
But I'll let someone from Python have a say on that.

I do believe it is not necessary, as an example www/zope213.
However, any feedback is always very welcome.

Best,

koobs requested changes to this revision.EditedMar 22 2016, 11:48 AM
koobs added a reviewer: koobs.
koobs added a subscriber: koobs.

Both ports should be prefixed, there are very few candidates these days that don't need to be: https://wiki.freebsd.org/Python/PortsPolicy

  • It's also preferable to use CHEESESHOP for DISTFILES (MASTER_SITES) unless there are compelling reasons (such as tests missing from PyPI source distribution (sdist)) to fetch sources from repositories. Both are available from PyPI
  • Add LICENSE_FILE if one exists in WRKSRC
  • If python ports provide console_scripts (scripts/commands in LOCALBASE/bin) use USE_PYTHON=concurrent to provide version-prefixed filenames for the chosen default Python version
This revision now requires changes to proceed.Mar 22 2016, 11:48 AM
araujo edited edge metadata.

Address @koobs suggestions, I opt to don't use CHEESESHOP as it seems
not follow correct the releases on github.

koobs requested changes to this revision.Apr 1 2016, 11:47 AM
koobs edited edge metadata.
koobs added inline comments.
benchmarks/py-naarad/Makefile
7 ↗(On Diff #14808)

Missing PKGNAMEPREFIX = ${PYTHON_PKGNAMEPREFIX}

benchmarks/py-zopkio/Makefile
6 ↗(On Diff #14808)

Missing PKGNAMEPREFIX = ${PYTHON_PKGNAMEPREFIX}

19 ↗(On Diff #14808)

Setting/overriding WRKSRC shouldn't be necessary for ports using USE_GITHUB

Preferably, use DISTNAME = Zopkio-${PORTVERSION} above, or GH_PROJECT = Zopkio, but the latter shouldn't be necessary with DISTNAME set as I believe GH_PROJECT defaults to DISTNAME

math/py-luminol/Makefile
7 ↗(On Diff #14808)

Missing PKGNAMEPREFIX = ${PYTHON_PKGNAMEPREFIX}

This revision now requires changes to proceed.Apr 1 2016, 11:47 AM
benchmarks/py-zopkio/Makefile
19 ↗(On Diff #14808)

For this case, the name of the port is zopkio, but the DISTNAME is Zopkio, I got few problems like the LICENSE_FILE, because the path doesn't match.

I would prefer keep simple with WRKSRC.

araujo edited edge metadata.

Address @koobs suggestions.

benchmarks/py-zopkio/Makefile
19 ↗(On Diff #14808)

Please, use either Zopkio as the PORTNAME, or put GH_PROJECT=Zopkio, but don't set either DISTNAME or WRKSRC.

araujo edited edge metadata.

address @mat suggestion.

Also, remove all the ${PORTSDIR}/ from DEPENDS lines.

benchmarks/py-naarad/Makefile
25 ↗(On Diff #15183)

remove bash, it is already there.

26–29 ↗(On Diff #15183)

Remove those lines.
As a side not, it should be ${LOCALBASE}

benchmarks/py-naarad/Makefile
26–27 ↗(On Diff #15187)

Like I said, these are not needed.

benchmarks/py-naarad/Makefile
26–27 ↗(On Diff #15187)

But gawk is not part of the default options like BASH.

https://www.freebsd.org/doc/en/books/porters-handbook/uses-shebangfix.html

benchmarks/py-naarad/Makefile
26–27 ↗(On Diff #15187)

Yes, you are right, but I also am right, those lines are not needed, I'll update the porter's handbook.

Remove SHEBANG_LANG= gawk @mat will update PortsHandbook too soon :)

benchmarks/py-naarad/Makefile
24 ↗(On Diff #15191)

You still need the SHEBANG_LANG line. Well, if you still have bad gawk shebangs, that is.

OK, now I guess I understood the SHEBANG_LANG.
Thanks @mat. :)

koobs edited edge metadata.

Accepted, with comment about lowercase(PORTNAME) preference

benchmarks/py-zopkio/Makefile
3 ↗(On Diff #15193)

Prefer lowercase(PORTNAME) but not 'strictly' necessary.

This revision is now accepted and ready to land.Apr 15 2016, 6:42 AM
benchmarks/py-zopkio/Makefile
3 ↗(On Diff #15193)

PORTNAME should be the same as upstream, there is absolutely no mention of lowercase in the porter's handbook.

This revision was automatically updated to reflect the committed changes.