Page MenuHomeFreeBSD

rtld/tests: Avoid function name conflict with libc opendir()
ClosedPublic

Authored by arichardson on Jul 5 2021, 8:40 AM.

Details

Summary

This prevents these tests from being compiled with ASAN since the asan
interceptors also define opendir() but matching the libc function.

Diff Detail

Repository
rG FreeBSD src repository
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.

Event Timeline

This revision is now accepted and ready to land.Jul 5 2021, 8:59 AM

We have fdopendir in libc I wonder if this won't be confusing. Maybe we should rename this to something like rtld_opendir.
But whatever name your choose this LGTM.