install and reboot; test various parts of /proc
Details
Diff Detail
- Repository
- rS FreeBSD src repository - subversion
- Lint
Lint Not Applicable - Unit
Tests Not Applicable
Event Timeline
sys/fs/procfs/procfs.c | ||
---|---|---|
102 ↗ | (On Diff #41707) | '__*' namespace not be used for regular code. Look at the style(9) how correct function body looks like. |
114 ↗ | (On Diff #41707) | same style isue. |
115 ↗ | (On Diff #41707) | return (); |
168 ↗ | (On Diff #41707) | Style, binary ops require space from both side of the sign. Since you changing the line, it must be fixed. |
sys/fs/procfs/procfs.c | ||
---|---|---|
116 ↗ | (On Diff #41713) | 0555 instead of 0500 like the others. Any suggestions on a better name? Maybe everyone_readexec or ugo for user-group-other ? |
sys/fs/procfs/procfs.c | ||
---|---|---|
124 ↗ | (On Diff #41713) | Somewhat unrelated to this patch, but is there a good reason why this isn't something like: return (procfs_attr(td, p, pn, vap, (RW << OWNER)); instead of magic numbers like 0600, 0555, ...? |
Also look at MAINTAINERS file.
sys/fs/procfs/procfs.c | ||
---|---|---|
116 ↗ | (On Diff #41713) | I.e. your 'global' is usually spelled as 'all'. I would also use 'rw', 're' etc instead of spelling out the whole words. |
sys/fs/procfs/procfs.c | ||
---|---|---|
116 ↗ | (On Diff #41730) | Is re here supposed to mean read + execute? If so, it should be spelled rx, cf. chgrp(1), chgrp(2) etc. |
124 ↗ | (On Diff #41713) | Anyone with enough Unix experience to be reading this code will immediately know what the numbers mean. The macros take longer to read and understand and become unwieldy in more complex cases (e.g. 0755). |