Page MenuHomeFreeBSD

devel/pear-PHP_CodeBrowser: unbreak
ClosedPublic

Authored by joneum on Oct 31 2017, 5:43 PM.

Details

Summary

Unbreak this port

While here switch to DISTVERSION

Add LICENSE

Approved by: xxx (mentor)
#Differential Revision: https://reviews.freebsd.org/Dxxxxx

Test Plan

Diff Detail

Repository
rP FreeBSD ports repository
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.

Event Timeline

You might want to take a look at the warnings

warning: phpunit/PHP_CodeBrowser requires package "phpunit/File_Iterator" (version >= 1.3.0)
phpunit/PHP_CodeBrowser can optionally use package "pear/Text_Highlighter" (version >= 0.7.1)
phpunit/PHP_CodeBrowser can optionally use package "phpunit/PHPUnit" (version >= 3.4.0)
phpunit/PHP_CodeBrowser can optionally use package "pear/PHP_CodeSniffer" (version >= 1.2.0)
phpunit/PHP_CodeBrowser can optionally use package "pear/PhpDocumentor" (version >= 1.4.3)

and decide whether you ant to depend on them.

devel/pear-PHP_CodeBrowser/Makefile
23 ↗(On Diff #34550)

This change is bogus.

devel/pear-PHP_CodeBrowser/Makefile
5 ↗(On Diff #34746)

Also, please try not to add too much churn to the repo, don't change this for the sake of changing it, only do it with a version change.

ready to land?

@mat asked you to revert the PORTREVERSION line :), and told you that the USES line looks bogus :) -- you might want to investigate that first.

The USES line was cleaned up days ago.

Sorry, thats my bad, I did not catch the changes :)

  • you can mark inline comments as done, that way, it's easier to see what you already addressed
  • also it is sometimes helpful to have a more descriptive update message than update :D
This revision is now accepted and ready to land.Nov 11 2017, 7:37 PM
This revision was automatically updated to reflect the committed changes.