Eliminate trivial wrappers for several iommu_gas functions. These wrappers serve no functional purpose.
Details
Tested with netperf on amd64. On arm64, a kernel with the IOMMU option compiles.
Diff Detail
- Repository
- rG FreeBSD src repository
- Lint
Lint Not Applicable - Unit
Tests Not Applicable
Event Timeline
The idea of these wrappers was to abstract function names, i.e. make them looking generic by removing name "gas". I'm not sure what "gas" stands for, but there is no such thing on arm64.
so with this I can use iommu_map() in my ARM Komeda display controller driver (part of cheribsd), not confusing anyone with 'gas'
sys/dev/drm/komeda/komeda_plane.c: error = iommu_map(iodom,
I believe that it stood for "guest address space".
I also considered renaming iommu_gas_map, etc. to iommu_map, etc., but that entailed more changes. Nonetheless, I would be happy to take that approach.
as you wish, I am more or less fine with 'guest address space' since it is not amd64-specific. But the approach would be good.
Is this gve_down() call needed, given that we already bought the interface down?