Page MenuHomeFreeBSD
Paste P292

devel/ispc with llvm90 on 11.2 amd64
ActivePublic

Authored by jbeich on Aug 7 2019, 9:23 AM.
=>> Building devel/ispc
build started at Tue Aug 6 15:35:23 CST 2019
port directory: /usr/ports/devel/ispc
package name: ispc-1.11.0_1
building for: FreeBSD 112amd64-default-job-04 11.2-RELEASE-p6 FreeBSD 11.2-RELEASE-p6 amd64
maintained by: yuri@FreeBSD.org
Makefile ident:
Poudriere version: 3.3.99.20190803
Host OSVERSION: 1300037
Jail OSVERSION: 1102000
Job Id: 04
---Begin Environment---
SHELL=/bin/csh
OSVERSION=1102000
UNAME_v=FreeBSD 11.2-RELEASE-p6
UNAME_r=11.2-RELEASE-p6
BLOCKSIZE=K
MAIL=/var/mail/root
WARNING_WAIT=0
STATUS=1
HOME=/root
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
LOCALBASE=/usr/local
USER=root
LIBEXECPREFIX=/usr/local/libexec/poudriere
POUDRIERE_VERSION=3.3.99.20190803
MASTERMNT=/poudriere/data/.m/112amd64-default/ref
DEV_WARNING_WAIT=0
POUDRIERE_BUILD_TYPE=bulk
PACKAGE_BUILDING=yes
SAVED_TERM=tmux-256color
GID=0
UID=0
PWD=/poudriere/data/.m/112amd64-default/ref/.p/pool
NO_WARNING_PKG_INSTALL_EOL=yes
P_PORTS_FEATURES=FLAVORS SELECTED_OPTIONS
MASTERNAME=112amd64-default
SCRIPTPREFIX=/usr/local/share/poudriere
OLDPWD=/poudriere/data/.m/112amd64-default/ref/.p
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
POUDRIEREPATH=/usr/local/bin/poudriere
---End Environment---
---Begin Poudriere Port Flags/Env---
PORT_FLAGS=
PKGENV=
FLAVOR=
DEPENDS_ARGS=
MAKE_ARGS=
---End Poudriere Port Flags/Env---
---Begin OPTIONS List---
---End OPTIONS List---
--MAINTAINER--
yuri@FreeBSD.org
--End MAINTAINER--
--CONFIGURE_ARGS--
--End CONFIGURE_ARGS--
--CONFIGURE_ENV--
PATH=/usr/local/llvm90/bin:/wrkdirs/usr/ports/devel/ispc/work/.bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin PYTHON="/usr/local/bin/python3.6" XDG_DATA_HOME=/wrkdirs/usr/ports/devel/ispc/work XDG_CONFIG_HOME=/wrkdirs/usr/ports/devel/ispc/work HOME=/wrkdirs/usr/ports/devel/ispc/work TMPDIR="/tmp" SHELL=/bin/sh CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--
--MAKE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/devel/ispc/work XDG_CONFIG_HOME=/wrkdirs/usr/ports/devel/ispc/work HOME=/wrkdirs/usr/ports/devel/ispc/work TMPDIR="/tmp" NO_PIE=yes MK_DEBUG_FILES=no MK_KERNEL_SYMBOLS=no SHELL=/bin/sh NO_LINT=YES DESTDIR=/wrkdirs/usr/ports/devel/ispc/work/stage PREFIX=/usr/local LOCALBASE=/usr/local CC="cc" CFLAGS="-O2 -pipe -fstack-protector-strong -fno-strict-aliasing " CPP="cpp" CPPFLAGS="" LDFLAGS=" -fstack-protector-strong " LIBS="" CXX="c++" CXXFLAGS="-O2 -pipe -fstack-protector-strong -fno-strict-aliasing " MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install -s -m 555" BSD_INSTALL_LIB="install -s -m 0644" BSD_INSTALL_SCRIPT="install -m 555" BSD_INSTALL_DATA="install -m 0644" BSD_INSTALL_MAN="install -m 444"
--End MAKE_ENV--
--PLIST_SUB--
CMAKE_BUILD_TYPE="release" PYTHON_INCLUDEDIR=include/python3.6m PYTHON_LIBDIR=lib/python3.6 PYTHON_PLATFORM=freebsd11 PYTHON_SITELIBDIR=lib/python3.6/site-packages PYTHON_SUFFIX=36 PYTHON_VER=3.6 PYTHON_VERSION=python3.6 PYTHON2="@comment " PYTHON3="" OSREL=11.2 PREFIX=%D LOCALBASE=/usr/local RESETPREFIX=/usr/local LIB32DIR=lib DOCSDIR="share/doc/ispc" EXAMPLESDIR="share/examples/ispc" DATADIR="share/ispc" WWWDIR="www/ispc" ETCDIR="etc/ispc"
--End PLIST_SUB--
--SUB_LIST--
PREFIX=/usr/local LOCALBASE=/usr/local DATADIR=/usr/local/share/ispc DOCSDIR=/usr/local/share/doc/ispc EXAMPLESDIR=/usr/local/share/examples/ispc WWWDIR=/usr/local/www/ispc ETCDIR=/usr/local/etc/ispc
--End SUB_LIST--
---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
FORCE_PACKAGE=yes
PACKAGE_BUILDING=yes
PACKAGE_BUILDING_FLAVORS=yes
#### /usr/local/etc/poudriere.d/make.conf ####
DEV_WARNING_WAIT=0
#NO_IGNORE=
# Minimize TeX dependency
devel_doxygen_UNSET += DOCS LATEX
# Bootstrapping isn't necessary for modern compilers and prevents taking
# advantage of native-xtools. GCC < 6 aren't C++11-compatible while
# Clang >= 6 and GCC >= 6 default to C++14.
lang_gcc6_UNSET += BOOTSTRAP
lang_gcc7_UNSET += BOOTSTRAP
lang_gcc8_UNSET += BOOTSTRAP
lang_gcc9_UNSET += BOOTSTRAP
# Workaround GCC/qemu crashes
.if ${MACHINE:Marm*}
math_ceres-solver_UNSET += OPENMP
graphics_colmap_UNSET += OPENMP
.endif
#### /usr/local/etc/poudriere.d/112amd64-make.conf ####
OPTIONS_SET += LIBEVENT
irc_bitlbee_UNSET += GLIB
lang_io_SET += Socket
# Prepare for random updates
OPTIONS_SET += X265 VAAPI PYGAME
# Prepare for Rust updates
www_seamonkey_SET += RUST
#DEFAULT_VERSIONS += rust=rust-nightly
# Prepare for ICU updates
OPTIONS_SET += ICU UNICODE
databases_sqlite3_UNSET += ICU
dns_libpsl_UNSET += IDN2
mail_sendmail_SET += SMTPUTF8
sysutils_gdisk_SET += UTF16
# Prepare for Boost updates
OPTIONS_SET += BOOST
audio_pms_SET += REGEX
databases_mariadb100-server_SET += OQGRAPH
databases_mariadb101-server_SET += OQGRAPH
databases_mariadb102-server_SET += OQGRAPH
databases_mariadb103-server_SET += OQGRAPH
databases_mariadb104-server_SET += OQGRAPH
devel_blitz_SET += SERIALIZATION
graphics_vigra_SET += NUMPY
misc_visp_SET += OGRE
science_tfel_SET += PYTHON
textproc_kiss-templates_SET += TEST
www_nghttp2_SET += ASIO
# Prepare for FFmpeg updates
OPTIONS_SET += FFMPEG
audio_libsoxr_SET += AVFFT
graphics_pqiv_SET += LIBAV
multimedia_tvheadend_SET += TRANSCODING
net_freeswitch_SET += ALL_MODULES
www_nginx_SET += HTTP_VIDEO_THUMBEXTRACTOR
www_nginx-devel_SET += HTTP_VIDEO_THUMBEXTRACTOR
#multimedia_gstreamer1-libav_UNSET += FFMPEG
# https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=235240
OPTIONS_SET += INOTIFY LIBINOTIFY FSMONITOR
#### /usr/ports/Mk/Scripts/ports_env.sh ####
_CCVERSION_921dbbb2=FreeBSD clang version 6.0.0 (tags/RELEASE_600/final 326565) (based on LLVM 6.0.0) Target: x86_64-unknown-freebsd11.2 Thread model: posix InstalledDir: /usr/bin
_ALTCCVERSION_921dbbb2=none
_CXXINTERNAL_acaad9ca=FreeBSD clang version 6.0.0 (tags/RELEASE_600/final 326565) (based on LLVM 6.0.0) Target: x86_64-unknown-freebsd11.2 Thread model: posix InstalledDir: /usr/bin "/usr/bin/ld" "--eh-frame-hdr" "-dynamic-linker" "/libexec/ld-elf.so.1" "--hash-style=both" "--enable-new-dtags" "-o" "a.out" "/usr/lib/crt1.o" "/usr/lib/crti.o" "/usr/lib/crtbegin.o" "-L/usr/lib" "/dev/null" "-lc++" "-lm" "-lgcc" "--as-needed" "-lgcc_s" "--no-as-needed" "-lc" "-lgcc" "--as-needed" "-lgcc_s" "--no-as-needed" "/usr/lib/crtend.o" "/usr/lib/crtn.o"
CC_OUTPUT_921dbbb2_58173849=yes
CC_OUTPUT_921dbbb2_9bdba57c=yes
CC_OUTPUT_921dbbb2_6a4fe7f5=yes
CC_OUTPUT_921dbbb2_6bcac02b=yes
CC_OUTPUT_921dbbb2_67d20829=yes
CC_OUTPUT_921dbbb2_bfa62e83=yes
CC_OUTPUT_921dbbb2_f0b4d593=yes
CC_OUTPUT_921dbbb2_308abb44=yes
CC_OUTPUT_921dbbb2_f00456e5=yes
CC_OUTPUT_921dbbb2_65ad290d=yes
CC_OUTPUT_921dbbb2_f2776b26=yes
CC_OUTPUT_921dbbb2_b2657cc3=yes
CC_OUTPUT_921dbbb2_380987f7=yes
CC_OUTPUT_921dbbb2_160933ec=yes
CC_OUTPUT_921dbbb2_fb62803b=yes
_OBJC_CCVERSION_921dbbb2=FreeBSD clang version 6.0.0 (tags/RELEASE_600/final 326565) (based on LLVM 6.0.0) Target: x86_64-unknown-freebsd11.2 Thread model: posix InstalledDir: /usr/bin
_OBJC_ALTCCVERSION_921dbbb2=none
ARCH=amd64
OPSYS=FreeBSD
_OSRELEASE=11.2-RELEASE-p6
OSREL=11.2
OSVERSION=1102000
PYTHONBASE=/usr/local
HAVE_COMPAT_IA32_KERN=YES
_SMP_CPUS=8
CONFIGURE_MAX_CMD_LEN=262144
HAVE_PORTS_ENV=1
#### Misc Poudriere ####
---End make.conf---
--Resource limits--
cpu time (seconds, -t) unlimited
file size (512-blocks, -f) unlimited
data seg size (kbytes, -d) 33554432
stack size (kbytes, -s) 524288
core file size (512-blocks, -c) unlimited
max memory size (kbytes, -m) unlimited
locked memory (kbytes, -l) unlimited
max user processes (-u) 63536
open files (-n) 1024
virtual mem size (kbytes, -v) unlimited
swap limit (kbytes, -w) unlimited
socket buffer size (bytes, -b) unlimited
pseudo-terminals (-p) unlimited
kqueues (-k) unlimited
umtx shared locks (-o) unlimited
--End resource limits--
=======================<phase: check-sanity >============================
===> License BSD3CLAUSE accepted by the user
===========================================================================
=======================<phase: pkg-depends >============================
===> ispc-1.11.0_1 depends on file: /usr/local/sbin/pkg - not found
===> Installing existing package /packages/All/pkg-1.11.1.txz
[112amd64-default-job-04] Installing pkg-1.11.1...
[112amd64-default-job-04] Extracting pkg-1.11.1: .......... done
===> ispc-1.11.0_1 depends on file: /usr/local/sbin/pkg - found
===> Returning to build of ispc-1.11.0_1
===========================================================================
=======================<phase: fetch-depends >============================
===========================================================================
=======================<phase: fetch >============================
===> License BSD3CLAUSE accepted by the user
===> ispc-1.11.0_1 depends on file: /usr/local/sbin/pkg - found
===> Fetching all distfiles required by ispc-1.11.0_1 for building
===========================================================================
=======================<phase: checksum >============================
===> License BSD3CLAUSE accepted by the user
===> ispc-1.11.0_1 depends on file: /usr/local/sbin/pkg - found
===> Fetching all distfiles required by ispc-1.11.0_1 for building
=> SHA256 Checksum OK for ispc-ispc-v1.11.0_GH0.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract >============================
===> License BSD3CLAUSE accepted by the user
===> ispc-1.11.0_1 depends on file: /usr/local/sbin/pkg - found
===> Fetching all distfiles required by ispc-1.11.0_1 for building
===> Extracting for ispc-1.11.0_1
=> SHA256 Checksum OK for ispc-ispc-v1.11.0_GH0.tar.gz.
===========================================================================
=======================<phase: patch-depends >============================
===========================================================================
=======================<phase: patch >============================
===> Patching for ispc-1.11.0_1
===> Applying FreeBSD patches for ispc-1.11.0_1
===========================================================================
=======================<phase: build-depends >============================
===> ispc-1.11.0_1 depends on executable: bison - not found
===> Installing existing package /packages/All/bison-3.4.1,1.txz
[112amd64-default-job-04] Installing bison-3.4.1,1...
[112amd64-default-job-04] `-- Installing gettext-runtime-0.20.1...
[112amd64-default-job-04] | `-- Installing indexinfo-0.3.1...
[112amd64-default-job-04] | `-- Extracting indexinfo-0.3.1: .... done
[112amd64-default-job-04] `-- Extracting gettext-runtime-0.20.1: .......... done
[112amd64-default-job-04] `-- Installing libtextstyle-0.20.1...
[112amd64-default-job-04] `-- Extracting libtextstyle-0.20.1: .......... done
[112amd64-default-job-04] `-- Installing m4-1.4.18_1,1...
[112amd64-default-job-04] `-- Extracting m4-1.4.18_1,1: .......... done
[112amd64-default-job-04] Extracting bison-3.4.1,1: .......... done
===> ispc-1.11.0_1 depends on executable: bison - found
===> Returning to build of ispc-1.11.0_1
===> ispc-1.11.0_1 depends on file: /usr/local/bin/cmake - not found
===> Installing existing package /packages/All/cmake-3.14.5_1.txz
[112amd64-default-job-04] Installing cmake-3.14.5_1...
[112amd64-default-job-04] `-- Installing curl-7.65.3...
[112amd64-default-job-04] | `-- Installing ca_root_nss-3.45...
[112amd64-default-job-04] | `-- Extracting ca_root_nss-3.45: ........ done
[112amd64-default-job-04] | `-- Installing libnghttp2-1.39.1_1...
[112amd64-default-job-04] | `-- Extracting libnghttp2-1.39.1_1: .......... done
[112amd64-default-job-04] `-- Extracting curl-7.65.3: .......... done
[112amd64-default-job-04] `-- Installing expat-2.2.6_1...
[112amd64-default-job-04] `-- Extracting expat-2.2.6_1: .......... done
[112amd64-default-job-04] `-- Installing jsoncpp-1.8.1_7...
[112amd64-default-job-04] `-- Extracting jsoncpp-1.8.1_7: .......... done
[112amd64-default-job-04] `-- Installing libarchive-3.3.3_1,1...
[112amd64-default-job-04] | `-- Installing liblz4-1.9.1,1...
[112amd64-default-job-04] | `-- Extracting liblz4-1.9.1,1: .......... done
[112amd64-default-job-04] | `-- Installing lzo2-2.10_1...
[112amd64-default-job-04] | `-- Extracting lzo2-2.10_1: .......... done
[112amd64-default-job-04] `-- Extracting libarchive-3.3.3_1,1: .......... done
[112amd64-default-job-04] `-- Installing libuv-1.30.1...
[112amd64-default-job-04] `-- Extracting libuv-1.30.1: .......... done
[112amd64-default-job-04] `-- Installing rhash-1.3.5...
[112amd64-default-job-04] `-- Extracting rhash-1.3.5: .......... done
[112amd64-default-job-04] Extracting cmake-3.14.5_1: .......... done
Message from ca_root_nss-3.45:
********************************* WARNING *********************************
FreeBSD does not, and can not warrant that the certification authorities
whose certificates are included in this package have in any way been
audited for trustworthiness or RFC 3647 compliance.
Assessment and verification of trust is the complete responsibility of the
system administrator.
*********************************** NOTE **********************************
This package installs symlinks to support root certificates discovery by
default for software that uses OpenSSL.
This enables SSL Certificate Verification by client software without manual
intervention.
If you prefer to do this manually, replace the following symlinks with
either an empty file or your site-local certificate bundle.
* /etc/ssl/cert.pem
* /usr/local/etc/ssl/cert.pem
* /usr/local/openssl/cert.pem
***************************************************************************
===> ispc-1.11.0_1 depends on file: /usr/local/bin/cmake - found
===> Returning to build of ispc-1.11.0_1
===> ispc-1.11.0_1 depends on executable: ninja - not found
===> Installing existing package /packages/All/ninja-1.9.0,2.txz
[112amd64-default-job-04] Installing ninja-1.9.0,2...
[112amd64-default-job-04] `-- Installing python36-3.6.9...
[112amd64-default-job-04] | `-- Installing libffi-3.2.1_3...
[112amd64-default-job-04] | `-- Extracting libffi-3.2.1_3: .......... done
[112amd64-default-job-04] | `-- Installing readline-8.0.0...
[112amd64-default-job-04] | `-- Extracting readline-8.0.0: .......... done
[112amd64-default-job-04] `-- Extracting python36-3.6.9: .......... done
[112amd64-default-job-04] Extracting ninja-1.9.0,2: ......... done
Message from python36-3.6.9:
===========================================================================
Note that some standard Python modules are provided as separate ports
as they require additional dependencies. They are available as:
py36-gdbm databases/py-gdbm@py36
py36-sqlite3 databases/py-sqlite3@py36
py36-tkinter x11-toolkits/py-tkinter@py36
===========================================================================
===> ispc-1.11.0_1 depends on executable: ninja - found
===> Returning to build of ispc-1.11.0_1
===> ispc-1.11.0_1 depends on file: /usr/local/bin/python3.6 - found
===========================================================================
=======================<phase: lib-depends >============================
===> ispc-1.11.0_1 depends on shared library: libLLVM.so - not found
===> Installing existing package /packages/All/llvm90-9.0.0.r1.txz
[112amd64-default-job-04] Installing llvm90-9.0.0.r1...
[112amd64-default-job-04] `-- Installing libedit-3.1.20190324,1...
[112amd64-default-job-04] `-- Extracting libedit-3.1.20190324,1: .......... done
[112amd64-default-job-04] `-- Installing libxml2-2.9.9...
[112amd64-default-job-04] `-- Extracting libxml2-2.9.9: .......... done
[112amd64-default-job-04] `-- Installing perl5-5.28.2...
[112amd64-default-job-04] `-- Extracting perl5-5.28.2: .......... done
[112amd64-default-job-04] `-- Installing z3-4.8.5_1...
[112amd64-default-job-04] `-- Extracting z3-4.8.5_1: .......... done
[112amd64-default-job-04] Extracting llvm90-9.0.0.r1: .......... done
Message from perl5-5.28.2:
The /usr/bin/perl symlink has been removed starting with Perl 5.20.
For shebangs, you should either use:
#!/usr/local/bin/perl
or
#!/usr/bin/env perl
The first one will only work if you have a /usr/local/bin/perl,
the second will work as long as perl is in PATH.
===> ispc-1.11.0_1 depends on shared library: libLLVM.so - found (/usr/local/llvm90/lib/libLLVM.so)
===> Returning to build of ispc-1.11.0_1
===========================================================================
=>> Recording filesystem state for prebuild... done
=======================<phase: configure >============================
===> ispc-1.11.0_1 depends on executable: bison - found
===> ispc-1.11.0_1 depends on file: /usr/local/bin/cmake - found
===> ispc-1.11.0_1 depends on executable: ninja - found
===> ispc-1.11.0_1 depends on file: /usr/local/bin/python3.6 - found
===> ispc-1.11.0_1 depends on shared library: libLLVM.so - found (/usr/local/llvm90/lib/libLLVM.so)
===> Configuring for ispc-1.11.0_1
===> Performing out-of-source build
/bin/mkdir -p /wrkdirs/usr/ports/devel/ispc/work/.build
-- The C compiler identification is Clang 9.0.0
-- The CXX compiler identification is Clang 9.0.0
-- Check for working C compiler: /usr/local/llvm90/bin/clang
-- Check for working C compiler: /usr/local/llvm90/bin/clang -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /usr/local/llvm90/bin/clang++
-- Check for working CXX compiler: /usr/local/llvm90/bin/clang++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Found LLVM LLVM_9_0
-- LLVM_CONFIG_EXECUTABLE: /usr/local/llvm90/bin/llvm-config
-- CLANG_EXECUTABLE: /usr/local/llvm90/bin/clang
-- LLVM_DIS_EXECUTABLE: /usr/local/llvm90/bin/llvm-dis
-- LLVM_AS_EXECUTABLE: /usr/local/llvm90/bin/llvm-as
-- FILE_CHECK_EXECUTABLE: /usr/local/llvm90/bin/FileCheck
-- GIT_BINARY: GIT_BINARY-NOTFOUND
-- M4 macro processor: /usr/bin/m4
-- Found PythonInterp: /usr/local/bin/python3.6 (found suitable version "3.6.9", minimum required is "2.7")
-- Found BISON: /usr/local/bin/bison (found suitable version "3.4.1", minimum required is "2.4")
-- Found FLEX: /usr/bin/flex (found suitable version "2.5.37", minimum required is "2.5")
-- Configuring done
-- Generating done
CMake Warning:
Manually-specified variables were not used by the project:
BOOST_PYTHON_SUFFIX
CMAKE_COLOR_MAKEFILE
CMAKE_MODULE_LINKER_FLAGS
CMAKE_SHARED_LINKER_FLAGS
CMAKE_VERBOSE_MAKEFILE
THREADS_HAVE_PTHREAD_ARG
-- Build files have been written to: /wrkdirs/usr/ports/devel/ispc/work/.build
===========================================================================
=======================<phase: build >============================
===> Building for ispc-1.11.0_1
[1/135] /usr/local/llvm90/bin/clang++ -O2 -pipe -fstack-protector-strong -fno-strict-aliasing -O2 -pipe -fstack-protector-strong -fno-strict-aliasing -MD -MT CMakeFiles/check_isa.dir/check_isa.cpp.o -MF CMakeFiles/check_isa.dir/check_isa.cpp.o.d -o CMakeFiles/check_isa.dir/check_isa.cpp.o -c /wrkdirs/usr/ports/devel/ispc/work/ispc-1.11.0/check_isa.cpp
[2/135] cd /wrkdirs/usr/ports/devel/ispc/work/ispc-1.11.0 && /usr/bin/m4 -Ibuiltins -DLLVM_VERSION=LLVM_9_0 -DBUILD_OS=UNIX builtins/dispatch.ll | "/usr/local/bin/python3.6" bitcode2cpp.py builtins/dispatch.ll --llvm_as /usr/local/llvm90/bin/llvm-as > /wrkdirs/usr/ports/devel/ispc/work/.build/./builtins-dispatch.cpp
[3/135] : && /usr/local/llvm90/bin/clang++ -O2 -pipe -fstack-protector-strong -fno-strict-aliasing -O2 -pipe -fstack-protector-strong -fno-strict-aliasing -fstack-protector-strong CMakeFiles/check_isa.dir/check_isa.cpp.o -o bin/check_isa && :
[4/135] cd /wrkdirs/usr/ports/devel/ispc/work/ispc-1.11.0 && /usr/bin/m4 -Ibuiltins -DLLVM_VERSION=LLVM_9_0 -DBUILD_OS=UNIX -DRUNTIME=64 builtins/target-avx2-i64x4.ll | "/usr/local/bin/python3.6" bitcode2cpp.py builtins/target-avx2-i64x4.ll 64bit --llvm_as /usr/local/llvm90/bin/llvm-as > /wrkdirs/usr/ports/devel/ispc/work/.build/./builtins-target-avx2-i64x4-64bit.cpp
FAILED: builtins-target-avx2-i64x4-64bit.cpp
cd /wrkdirs/usr/ports/devel/ispc/work/ispc-1.11.0 && /usr/bin/m4 -Ibuiltins -DLLVM_VERSION=LLVM_9_0 -DBUILD_OS=UNIX -DRUNTIME=64 builtins/target-avx2-i64x4.ll | "/usr/local/bin/python3.6" bitcode2cpp.py builtins/target-avx2-i64x4.ll 64bit --llvm_as /usr/local/llvm90/bin/llvm-as > /wrkdirs/usr/ports/devel/ispc/work/.build/./builtins-target-avx2-i64x4-64bit.cpp
/usr/local/llvm90/bin/llvm-as: assembly parsed, but does not verify as correct!
immarg operand has non-immediate parameter
%scale8 = trunc i32 %scale to i8
%v = call <4 x i32> @llvm.x86.avx2.gather.d.d(<4 x i32> undef, i8* %ptr, <4 x i32> %offsets, <4 x i32> %vecmask, i8 %scale8)
immarg operand has non-immediate parameter
%scale8 = trunc i32 %scale to i8
%v = call <4 x i32> @llvm.x86.avx2.gather.q.d.256(<4 x i32> undef, i8* %ptr, <4 x i64> %offsets, <4 x i32> %vecmask, i8 %scale8)
immarg operand has non-immediate parameter
%scale8 = trunc i32 %scale to i8
%v = call <4 x float> @llvm.x86.avx2.gather.d.ps(<4 x float> undef, i8* %ptr, <4 x i32> %offsets, <4 x float> %mask, i8 %scale8)
immarg operand has non-immediate parameter
%scale8 = trunc i32 %scale to i8
%v = call <4 x float> @llvm.x86.avx2.gather.q.ps.256(<4 x float> undef, i8* %ptr, <4 x i64> %offsets, <4 x float> %mask, i8 %scale8)
immarg operand has non-immediate parameter
%scale8 = trunc i32 %scale to i8
%v = call <4 x i64> @llvm.x86.avx2.gather.d.q.256(<4 x i64> undef, i8* %ptr, <4 x i32> %offsets, <4 x i64> %vecmask, i8 %scale8)
immarg operand has non-immediate parameter
%scale8 = trunc i32 %scale to i8
%v = call <4 x i64> @llvm.x86.avx2.gather.q.q.256(<4 x i64> undef, i8* %ptr, <4 x i64> %offsets, <4 x i64> %vecmask, i8 %scale8)
immarg operand has non-immediate parameter
%scale8 = trunc i32 %scale to i8
%v = call <4 x double> @llvm.x86.avx2.gather.d.pd.256(<4 x double> undef, i8* %ptr, <4 x i32> %offsets, <4 x double> %vecmask, i8 %scale8)
immarg operand has non-immediate parameter
%scale8 = trunc i32 %scale to i8
%v = call <4 x double> @llvm.x86.avx2.gather.q.pd.256(<4 x double> undef, i8* %ptr, <4 x i64> %offsets, <4 x double> %vecmask, i8 %scale8)
[5/135] cd /wrkdirs/usr/ports/devel/ispc/work/ispc-1.11.0 && /usr/bin/m4 -Ibuiltins -DLLVM_VERSION=LLVM_9_0 -DBUILD_OS=UNIX -DRUNTIME=32 builtins/target-avx2-i64x4.ll | "/usr/local/bin/python3.6" bitcode2cpp.py builtins/target-avx2-i64x4.ll 32bit --llvm_as /usr/local/llvm90/bin/llvm-as > /wrkdirs/usr/ports/devel/ispc/work/.build/./builtins-target-avx2-i64x4-32bit.cpp
FAILED: builtins-target-avx2-i64x4-32bit.cpp
cd /wrkdirs/usr/ports/devel/ispc/work/ispc-1.11.0 && /usr/bin/m4 -Ibuiltins -DLLVM_VERSION=LLVM_9_0 -DBUILD_OS=UNIX -DRUNTIME=32 builtins/target-avx2-i64x4.ll | "/usr/local/bin/python3.6" bitcode2cpp.py builtins/target-avx2-i64x4.ll 32bit --llvm_as /usr/local/llvm90/bin/llvm-as > /wrkdirs/usr/ports/devel/ispc/work/.build/./builtins-target-avx2-i64x4-32bit.cpp
/usr/local/llvm90/bin/llvm-as: assembly parsed, but does not verify as correct!
immarg operand has non-immediate parameter
%scale8 = trunc i32 %scale to i8
%v = call <4 x i32> @llvm.x86.avx2.gather.d.d(<4 x i32> undef, i8* %ptr, <4 x i32> %offsets, <4 x i32> %vecmask, i8 %scale8)
immarg operand has non-immediate parameter
%scale8 = trunc i32 %scale to i8
%v = call <4 x i32> @llvm.x86.avx2.gather.q.d.256(<4 x i32> undef, i8* %ptr, <4 x i64> %offsets, <4 x i32> %vecmask, i8 %scale8)
immarg operand has non-immediate parameter
%scale8 = trunc i32 %scale to i8
%v = call <4 x float> @llvm.x86.avx2.gather.d.ps(<4 x float> undef, i8* %ptr, <4 x i32> %offsets, <4 x float> %mask, i8 %scale8)
immarg operand has non-immediate parameter
%scale8 = trunc i32 %scale to i8
%v = call <4 x float> @llvm.x86.avx2.gather.q.ps.256(<4 x float> undef, i8* %ptr, <4 x i64> %offsets, <4 x float> %mask, i8 %scale8)
immarg operand has non-immediate parameter
%scale8 = trunc i32 %scale to i8
%v = call <4 x i64> @llvm.x86.avx2.gather.d.q.256(<4 x i64> undef, i8* %ptr, <4 x i32> %offsets, <4 x i64> %vecmask, i8 %scale8)
immarg operand has non-immediate parameter
%scale8 = trunc i32 %scale to i8
%v = call <4 x i64> @llvm.x86.avx2.gather.q.q.256(<4 x i64> undef, i8* %ptr, <4 x i64> %offsets, <4 x i64> %vecmask, i8 %scale8)
immarg operand has non-immediate parameter
%scale8 = trunc i32 %scale to i8
%v = call <4 x double> @llvm.x86.avx2.gather.d.pd.256(<4 x double> undef, i8* %ptr, <4 x i32> %offsets, <4 x double> %vecmask, i8 %scale8)
immarg operand has non-immediate parameter
%scale8 = trunc i32 %scale to i8
%v = call <4 x double> @llvm.x86.avx2.gather.q.pd.256(<4 x double> undef, i8* %ptr, <4 x i64> %offsets, <4 x double> %vecmask, i8 %scale8)
[6/135] cd /wrkdirs/usr/ports/devel/ispc/work/ispc-1.11.0 && /usr/bin/m4 -Ibuiltins -DLLVM_VERSION=LLVM_9_0 -DBUILD_OS=UNIX -DRUNTIME=32 builtins/target-avx1-i64x4.ll | "/usr/local/bin/python3.6" bitcode2cpp.py builtins/target-avx1-i64x4.ll 32bit --llvm_as /usr/local/llvm90/bin/llvm-as > /wrkdirs/usr/ports/devel/ispc/work/.build/./builtins-target-avx1-i64x4-32bit.cpp
[7/135] cd /wrkdirs/usr/ports/devel/ispc/work/ispc-1.11.0 && /usr/bin/m4 -Ibuiltins -DLLVM_VERSION=LLVM_9_0 -DBUILD_OS=UNIX -DRUNTIME=64 builtins/target-avx11-i64x4.ll | "/usr/local/bin/python3.6" bitcode2cpp.py builtins/target-avx11-i64x4.ll 64bit --llvm_as /usr/local/llvm90/bin/llvm-as > /wrkdirs/usr/ports/devel/ispc/work/.build/./builtins-target-avx11-i64x4-64bit.cpp
[8/135] cd /wrkdirs/usr/ports/devel/ispc/work/ispc-1.11.0 && /usr/bin/m4 -Ibuiltins -DLLVM_VERSION=LLVM_9_0 -DBUILD_OS=UNIX -DRUNTIME=64 builtins/target-avx1-i64x4.ll | "/usr/local/bin/python3.6" bitcode2cpp.py builtins/target-avx1-i64x4.ll 64bit --llvm_as /usr/local/llvm90/bin/llvm-as > /wrkdirs/usr/ports/devel/ispc/work/.build/./builtins-target-avx1-i64x4-64bit.cpp
[9/135] cd /wrkdirs/usr/ports/devel/ispc/work/ispc-1.11.0 && /usr/bin/m4 -Ibuiltins -DLLVM_VERSION=LLVM_9_0 -DBUILD_OS=UNIX -DRUNTIME=32 builtins/target-avx11-i64x4.ll | "/usr/local/bin/python3.6" bitcode2cpp.py builtins/target-avx11-i64x4.ll 32bit --llvm_as /usr/local/llvm90/bin/llvm-as > /wrkdirs/usr/ports/devel/ispc/work/.build/./builtins-target-avx11-i64x4-32bit.cpp
[10/135] cd /wrkdirs/usr/ports/devel/ispc/work/ispc-1.11.0 && /usr/bin/m4 -Ibuiltins -DLLVM_VERSION=LLVM_9_0 -DBUILD_OS=UNIX -DRUNTIME=32 builtins/target-avx1.ll | "/usr/local/bin/python3.6" bitcode2cpp.py builtins/target-avx1.ll 32bit --llvm_as /usr/local/llvm90/bin/llvm-as > /wrkdirs/usr/ports/devel/ispc/work/.build/./builtins-target-avx1-32bit.cpp
[11/135] cd /wrkdirs/usr/ports/devel/ispc/work/ispc-1.11.0 && /usr/bin/m4 -Ibuiltins -DLLVM_VERSION=LLVM_9_0 -DBUILD_OS=UNIX -DRUNTIME=64 builtins/target-avx1.ll | "/usr/local/bin/python3.6" bitcode2cpp.py builtins/target-avx1.ll 64bit --llvm_as /usr/local/llvm90/bin/llvm-as > /wrkdirs/usr/ports/devel/ispc/work/.build/./builtins-target-avx1-64bit.cpp
ninja: build stopped: subcommand failed.
===> Compilation failed unexpectedly.
Try to set MAKE_JOBS_UNSAFE=yes and rebuild before reporting the failure to
the maintainer.
*** Error code 1
Stop.
make: stopped in /usr/ports/devel/ispc
=>> Cleaning up wrkdir
===> Cleaning for ispc-1.11.0_1
build of devel/ispc | ispc-1.11.0_1 ended at Tue Aug 6 15:38:48 CST 2019
build time: 00:03:26
!!! build failure encountered !!!

Event Timeline

jbeich edited the content of this paste. (Show Details)Aug 7 2019, 9:23 AM
jbeich changed the title of this paste from untitled to devel/ispc with llvm90 on 11.2 amd64.
jbeich added a subscriber: yuri.Aug 7 2019, 9:24 AM