Page MenuHomeFreeBSD

sysutils/rubygem-bosh_cli: Make version requirement on `json_pure` less struct
ClosedPublic

Authored by dumbbell on Jan 12 2017, 5:51 PM.

Details

Summary

After the upgrade of the json_pure gem, the BOSH CLI broke because it has a strict requirement on the version minor.

The patch simply release that strict requirement, like it is already done for other dependencies.

Diff Detail

Repository
rP FreeBSD ports repository
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.

Event Timeline

dumbbell updated this revision to Diff 23932.Jan 12 2017, 5:51 PM
dumbbell retitled this revision from to sysutils/rubygem-bosh_cli: Make version requirement on `json_pure` less struct.
dumbbell updated this object.
dumbbell edited the test plan for this revision. (Show Details)
dumbbell added reviewers: Ruby, antoine, bapt.
antoine requested changes to this revision.Jan 12 2017, 6:40 PM
antoine edited edge metadata.

PORTREVISION has to be bumped to 1 as the package changes.

I assume you run tested it?

This revision now requires changes to proceed.Jan 12 2017, 6:40 PM
dumbbell updated this revision to Diff 23936.Jan 12 2017, 6:56 PM
dumbbell edited edge metadata.

Bump PORTREVISION

I assume you run tested it?

Yes, I used the tool the whole day at work.

antoine accepted this revision.Jan 12 2017, 7:00 PM
antoine edited edge metadata.

looks fine, thanks!

This revision is now accepted and ready to land.Jan 12 2017, 7:00 PM
This revision was automatically updated to reflect the committed changes.