Previously the flag returned by cap_getmode was not described explicitly in the man page.
Details
Details
Diff Detail
Diff Detail
- Lint
Lint Skipped - Unit
Tests Skipped
Event Timeline
lib/libc/sys/cap_enter.2 | ||
---|---|---|
87–91 | Alternatively: The cap_getmode function sets the flag to a non-zero value if the process is in capability mode, or zero if the process is not in capability mode. |
lib/libc/sys/cap_enter.2 | ||
---|---|---|
87–91 | Some of the "if not" logic makes it kind of hard to read ("don't do what Donny Don't doesn't do!"). Maybe rearrange? .Fn cap_getmode returns a non-zero value when the process is in capability mode. A zero value means the process is not in capability mode. or... When the process is in capability mode, .Fn cap_getmode returns a non-zero value. A zero value means the process is not in capability mode. |
lib/libc/sys/cap_enter.2 | ||
---|---|---|
87–91 | Note that the flag (passed in the u_int *modep argument) is set to zero/non-zero to indicate if it is in capability mode, not the return value. But I prefer the way you formulated it, indeed. How does this sound: When the process is in capability mode, .Fn cap_getmode sets the flag to a non-zero value. A zero value means the process is not in capability mode. |
lib/libc/sys/cap_enter.2 | ||
---|---|---|
88 | Much better. But I still think there should be a comma for a pause after "mode". |