Page MenuHomeFreeBSD

science/InsightToolkit: Update to 4.10.0
ClosedPublic

Authored by woodsb02 on Jun 6 2016, 5:55 PM.

Details

Summary

science/InsightToolkit: Update to 4.10.0

Changes this release:

http://public.kitware.com/pipermail/community/2016-June/011491.html
Test Plan

poudriere testport science/InsightToolkit

Diff Detail

Repository
rP FreeBSD ports repository
Lint
No Linters Available
Unit
No Unit Test Coverage
Build Status
Buildable 4128
Build 4171: arc lint + arc unit

Event Timeline

woodsb02 retitled this revision from to science/InsightToolkit: Update to 4.10.0.
woodsb02 updated this object.
woodsb02 edited the test plan for this revision. (Show Details)
woodsb02 added reviewers: adamw, mat, koobs.
science/InsightToolkit/Makefile
14

If you've added USES=jpeg, can you remove this line?

science/InsightToolkit/Makefile
14

Oh yes, absolutely. That is interesting that I had that line in there and the stage-qa still warned I needed to add the link. I guess because it is linking to a different library.

====> Running Q/A tests (stage-qa)
Error: /usr/local/lib/libITKIOHDF5-4.10.so.1 is linked to /usr/local/lib/libsz.so.2 from science/szip but it is not declared as a dependency
Warning: you need LIB_DEPENDS+=libsz.so:science/szip
Error: /usr/local/lib/libITKIOJPEG-4.10.so.1 is linked to /usr/local/lib/libjpeg.so.8 from graphics/jpeg-turbo but it is not declared as a dependency
Warning: you need USES+=jpeg

Remove duplicate LIB_DEPENDS on graphics/libjpeg-turbo now that we have USES=jpeg

adamw edited edge metadata.
adamw added inline comments.
science/InsightToolkit/Makefile
36

With > 8,000 lines that would need to be updated at the next minor bump, this is a really good call!

This revision is now accepted and ready to land.Jun 6 2016, 6:05 PM
This revision was automatically updated to reflect the committed changes.

Do other ports depend on this ? Will they find the header automagically ?

In D6737#141987, @mat wrote:

Do other ports depend on this ? Will they find the header automagically ?

Hi Mathieu,
I assume you are referring to the need to maybe update USE_LDCONFIG?
There are currently no ports that depend on this library, but I hadn't noticed it until now and it should probably be fixed anyway.
Regards,
Ben

In D6737#141987, @mat wrote:

Do other ports depend on this ? Will they find the header automagically ?

Hi Mathieu,
I assume you are referring to the need to maybe update USE_LDCONFIG?
There are currently no ports that depend on this library, but I hadn't noticed it until now and it should probably be fixed anyway.

No, no, I'm talking about headers, the directory changed, (ITK-4.9 -> ITK-4.10), will people who use this still be able to build their stuff ?
The .so's names change too, so USE_LDCONFIG wouldn't change anything. And binaries linked with them won't work any more.
I guess people will complain if it's broken for them :-)

In D6737#141997, @mat wrote:

No, no, I'm talking about headers, the directory changed, (ITK-4.9 -> ITK-4.10), will people who use this still be able to build their stuff ?
The .so's names change too, so USE_LDCONFIG wouldn't change anything. And binaries linked with them won't work any more.
I guess people will complain if it's broken for them :-)

Good point. There are no ports that depend on this port, but this will be a difficulty for anyone using it outside of the ports system. This is how it is setup by default by the CMakeLists.txt here.

I could set the following CMake variables to change it from these defaults, but perhaps sticking with the upstream defaults is better?

On another note, the USE_LDCONFIG directory seems to be wrong, as libraries are no longer installed in ${PREFIX}/lib/InsightToolkit, but simply ${PREFIX}/lib. So I think USE_LDCONFIG should just be set to "yes"?