Page MenuHomeFreeBSD

*/*: properly depend on Maven package
ClosedPublic

Authored by michaelo on Mar 5 2024, 3:26 PM.
Tags
None
Referenced Files
Unknown Object (File)
Fri, Jul 5, 6:33 PM
Unknown Object (File)
Thu, Jul 4, 4:20 PM
Unknown Object (File)
Thu, Jul 4, 12:28 PM
Unknown Object (File)
Thu, Jul 4, 3:32 AM
Unknown Object (File)
Thu, Jul 4, 1:01 AM
Unknown Object (File)
Sat, Jun 22, 4:40 PM
Unknown Object (File)
Sat, Jun 22, 7:34 AM
Unknown Object (File)
Tue, Jun 18, 9:28 AM
Subscribers
None

Details

Summary

devel/maven and devel/maven39 do not provide mvn(1) from LOCALBASE that
one comes from devel/maven-wrapper instead. Therefore, one should depend
on the package rather than a non-existing executable/script.

Approved by: jrm (mentor), otis (mentor), vvd, yuri

Diff Detail

Repository
R11 FreeBSD ports repository
Lint
Lint Not Applicable
Unit
Tests Not Applicable

Event Timeline

michaelo created this revision.

I think you can add java/eclipse here too.
Probably https://reviews.freebsd.org/D44153 isn't actual anymore.

In D44229#1008960, @vvd wrote:

I think you can add java/eclipse here too.
Probably https://reviews.freebsd.org/D44153 isn't actual anymore.

Alright, will do. I intentionally didn't touch it because you were working on.

This revision is now accepted and ready to land.Mar 5 2024, 5:56 PM

FYI, devel/eclipse failed in my 15.0-CURRENT 1500008 amd64 jail.

http://pkg.ftfl.ca/data/15amd64-default/2024-03-05_13h23m40s/logs/errors/eclipse-4.24_2.log

It doesn't seem like this change should have any effect, but can you verify this?

In D44229#1009025, @jrm wrote:

FYI, devel/eclipse failed in my 15.0-CURRENT 1500008 amd64 jail.

http://pkg.ftfl.ca/data/15amd64-default/2024-03-05_13h23m40s/logs/errors/eclipse-4.24_2.log

It doesn't seem like this change should have any effect, but can you verify this?

Not related:

install manually.
===>   eclipse-4.24_2 depends on executable: git - found
===>   Returning to build of eclipse-4.24_2
===>   eclipse-4.24_2 depends on package: maven>0 - not found
===>   Installing existing package /packages/All/maven-3.8.8_1.pkg
[15amd64-default-job-01] Installing maven-3.8.8_1...
[15amd64-default-job-01] `-- Installing maven-wrapper-2...
[15amd64-default-job-01] `-- Extracting maven-wrapper-2: ... done
[15amd64-default-job-01] `-- Installing openjdk8-8.402.06.1_1...

the failure is a heap space shortage:

[INFO] Finished at: 2024-03-05T18:14:56Z
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal org.eclipse.tycho:tycho-p2-director-plugin:3.0.0-SNAPSHOT:archive-products (archive-products) on project eclipse.platform.repository: Error packing product: Problem creating zip: Execution exception: Java heap space -> [Help 1]
[ERROR]

One needs to set MAVEN_OPTS=-Xmx2G or similar and try again. Could also be just 15 specific.

I don't think I have the right of approval revisions. But I'll set it.

This revision was automatically updated to reflect the committed changes.