We have (two versions) of MS() and SM() macros which we use throughout
the wireless code. Change all but three places (ath_hal, rtwn, and rsu)
to the newly provided _IEEE80211_MASKSHIFT() and _IEEE80211_SHIFTMASK()
macros. Also change one internal case using both _S and _M instead of
just _S away from _M (leave others, such as rsu).
This has been done semi-mechanically. No functional changes intended.
TODO: improve line-wrapping after this change before commit, if the
new macro names are generally acceptable.
Requested by: gnn (D26091) Sponsored by: Rubicon Communications, LLC (d/b/a "Netgate")