No functional changes.
Most of the routing flags are stored in the netxtop instead of rtentry.
Rename rt->rt_flags to rt->rte_flags to simplify reading/modifying code checking routing flags.
In the new multipath code, rt->rt_nhop may actually point to nexthop group instead of nhop.
To ease transition, reduce the amount of rt_nhop->... accesses.