Page MenuHomeFreeBSD

Rename rt_flags to rte_flags && reduce number of rt_nhop accesses.
ClosedPublic

Authored by melifaro on Aug 21 2020, 11:06 PM.

Details

Summary

No functional changes.

Most of the routing flags are stored in the netxtop instead of rtentry.
Rename rt->rt_flags to rt->rte_flags to simplify reading/modifying code checking routing flags.

In the new multipath code, rt->rt_nhop may actually point to nexthop group instead of nhop.
To ease transition, reduce the amount of rt_nhop->... accesses.

Diff Detail

Repository
rS FreeBSD src repository
Lint
Lint OK
Unit
No Unit Test Coverage
Build Status
Buildable 33102
Build 30473: arc lint + arc unit

Event Timeline

melifaro retitled this revision from Rename rt_flags to rte_flags && reduce number of rt_nhop accesses. Most of the routing flags are stored in the netxtop instead of rtentry. Rename `rt->rt_flags` to `rt->rte_flags` to simplify reading of flags checking code. In the new... to Rename rt_flags to rte_flags && reduce number of rt_nhop accesses..Aug 21 2020, 11:08 PM
melifaro edited the summary of this revision. (Show Details)
melifaro added a reviewer: network.
This revision was not accepted when it landed; it landed in state Needs Review.Aug 22 2020, 7:31 PM
This revision was automatically updated to reflect the committed changes.