PR: 230289 Submitted by: Yasuhiro KIMURA <firstname.lastname@example.org> (initial revision) meta (myself) Reported by: #Reviewed by: Approved by: Obtained from: MFC after: MFH: Relnotes: Security: Sponsored by: #Differential Revision: https://reviews.freebsd.org/D20000
- Group Reviewers
Ruby O5: Ports Framework (Owns No Changed Paths) portmgr
- rP500480: lang/ruby2: Remove dbm library and replace it with databases/rubygem-dbm
I think you could simplify the option names by removing BACKEND_ prefix.
Please group settings of each option (e.g. BDB_*) together. It's easier to read.
And it's easier to find out duplicate or conflicts, e.g. duplicate BACKEND_BDB_USES in line 21 and 27.
It is not needed. This gem does not require libunwind.
Please use https://github.com/ruby/dbm (the homepage link of this gem).
I would like to keep it in the same order (ext/dbm ext/gdbm) as the pkg-message.