Page MenuHomeFreeBSD

emulators/virtualbox-ose-additions: Remove devclass from DRIVER_MODULE on recent main.
ClosedPublic

Authored by jhb on Jul 26 2022, 6:38 PM.

Diff Detail

Repository
R11 FreeBSD ports repository
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.

Event Timeline

jhb requested review of this revision.Jul 26 2022, 6:38 PM
madpilot added a subscriber: madpilot.

I'm approving since I guess you already tested it and looks correct, but I'm unable to test this till late next week.

This revision is now accepted and ready to land.Aug 12 2022, 5:42 PM

Hi,

I tested this patch at runtime and it works fine.

Thanks!

P.S. Sorry, please hold a little, I now noticed I did not properly test this. Give me a little more time!

Hi again. A first test on 13.1 is not working. Which is strange, this should be a NOP there, if I understand correctly.

It's going to a black screen in the VM when starting Xorg.

I need more time to test on head and verify my findings.

I'm having a problem properly testing this.

I'm stumbling on other issues.

On 13.1 the module loads ands seems to work though. What is broken there for me at present, using the head of the ports repo is the virtualbox X11 driver.

On head (installed from FreeBSD-14.0-CURRENT-amd64-20220812-6a70a0c8bfa-257314-disc1.iso) I get a kernel panic due to a giant locking issue, both with and without your patch.

I'm trying to understand what is going on. More help would be appreciated, since I have no idea what could be causing these two issues.