Page MenuHomeFreeBSD

update the mount_nfs.8 man page for a change in default minor version for NFSv4
ClosedPublic

Authored by rmacklem on Jun 15 2021, 12:44 AM.

Details

Summary

A planned patch will change an NFSv4 mount from using minor
version 0 by default to using the highest minor version supported
by the NFSv4 server, by default.
This semantics change was discussed on freebsd-current@ and was
supported by those involved in the discussion.

The actual source patch is a small change that does not seem to need review.

Test Plan

Read updated "man mount_nfs".

For the actual default change in src, mounts were
done against a server that supported a highest minor
version (as specified by vfs.nfsd.server_max_minorversion4)
of 2, 1, and 0.
The mounts worked and the packet captures were what
was epected.

Diff Detail

Repository
rG FreeBSD src repository
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.

Event Timeline

rmacklem created this revision.

mount_nfs.8.sav should not be present here.

Sorry, I don't understand your comment. mount_nfs.8.sav is
simply the old (what is in "main") version that is being patched.

I do not use git until something is reviewed and I am upstreaming it.

Sorry, I don't understand your comment. mount_nfs.8.sav is
simply the old (what is in "main") version that is being patched.

I do not use git until something is reviewed and I am upstreaming it.

It confuses arc patch.

sbin/mount_nfs/mount_nfs.8
230

nfsstat is (1), not (8).

Fixed nfsstat to be 1 instead of 8.

rmacklem added inline comments.
sbin/mount_nfs/mount_nfs.8
230

Good catch. Not a part of this change, but might as well fi it now.

This revision is now accepted and ready to land.Jun 26 2021, 8:14 AM
This revision was automatically updated to reflect the committed changes.
rmacklem marked an inline comment as done.