Page MenuHomeFreeBSD

devel/libgrading: update v0.1.2 -> v0.1.6
ClosedPublic

Authored by jonathan on Feb 7 2019, 11:04 PM.
Tags
None
Referenced Files
Unknown Object (File)
Fri, Jun 7, 7:14 AM
Unknown Object (File)
Tue, Jun 4, 7:12 AM
Unknown Object (File)
Tue, Jun 4, 3:56 AM
Unknown Object (File)
Tue, Jun 4, 3:56 AM
Unknown Object (File)
Mon, Jun 3, 11:01 PM
Unknown Object (File)
Mon, Jun 3, 11:01 PM
Unknown Object (File)
Sun, Jun 2, 2:14 AM
Unknown Object (File)
Thu, May 30, 6:53 PM
Subscribers

Details

Summary
  • Add support for Gradescope
  • Fix SOVERSION
  • Various minor fixups

Diff Detail

Repository
rP FreeBSD ports repository
Lint
Lint Not Applicable
Unit
Tests Not Applicable

Event Timeline

tobik requested changes to this revision.Feb 8 2019, 7:58 AM
tobik added a subscriber: tobik.

This fails check-plist:

===> Checking for items in STAGEDIR missing from pkg-plist
Error: Orphaned: lib/libgrading.so.0.1.4
===> Checking for items in pkg-plist which are not in STAGEDIR
===> Error: Plist issues found.
*** Error code 1
This revision now requires changes to proceed.Feb 8 2019, 7:58 AM
matthew added a subscriber: matthew.
This comment was removed by matthew.
matthew requested changes to this revision.Feb 8 2019, 8:00 AM

Ooops. I was too quick to accept there. Needs pkg-plist updating as @tobik has shown

  • Add new library to plist
  • Fix library version.
  • Fix a portlint warning.
  • Update patch file (new line numbers, etc.).

Thanks for the feedback: I've added the missing file and done a little extra tidy-up that portlint -A suggested while I'm at it.

  • Update to v0.1.7 (w/upstream patch adoption).

Just for good measure, I also updated the upstream code to incorporate the __FreeBSD_version_ patch; I'm now looking to update the port to v0.1.7.

This revision is now accepted and ready to land.Feb 8 2019, 8:30 PM
This revision was automatically updated to reflect the committed changes.