- Added support to issue HWRM_FUNC_VF_CFG if driver running with VF
- Corrected logic to find VF or NPAR
- Cleaned and Consolidated BNXT flags
- Added additional check for WoL enable
Ran sanity tests as VF driver on both ESXi and Linux Hyper visors.
|953 ↗||(On Diff #33211)|
Possibly this function should be renamed or split?
The implication of bnxt_hwrm_func_cfg() is that it calls HWRM_FUNC_CFG. Maybe bnxt_cfg_async_cr()? Or split into bnxt_hwrm_func_cfg() and bnxt_hwrm_func_vf_cfg() and have the caller choose the correct function?