HomeFreeBSD

Rename aiocblist to kaiocb and use consistent variable names.

Description

Rename aiocblist to kaiocb and use consistent variable names.

Typically <foo>list is used for a structure that holds a list head in
FreeBSD, not for members of a list. As such, rename 'struct aiocblist'
to 'struct kaiocb' (the kernel version of 'struct aiocb').

While here, use more consistent variable names for AIO control blocks:

  • Use 'job' instead of 'aiocbe', 'cb', 'cbe', or 'iocb' for kernel job objects.
  • Use 'jobn' instead of 'cbn' for use with TAILQ_FOREACH_SAFE().
  • Use 'sjob' and 'sjobn' instead of 'scb' and 'scbn' for fsync jobs.
  • Use 'ujob' instead of 'aiocbp', 'job', 'uaiocb', or 'uuaiocb' to hold a user pointer to a 'struct aiocb'.
  • Use 'ujobp' instead of 'aiocbp' for a user pointer to a 'struct aiocb *'.

Reviewed by: kib
Sponsored by: Chelsio Communications
Differential Revision: https://reviews.freebsd.org/D5125

Details

Provenance
jhbAuthored on
Reviewer
kib
Differential Revision
D5125: Rename aiocblist to kaiocb and use consistent variable names.
Parents
rS295330: Plug a vm_page leak introduced in r292373.
Branches
Unknown
Tags
Unknown