HomeFreeBSD

MFH: r502951 x11/cinnamon: Remove unnecessary version check

Description

MFH: r502951 x11/cinnamon: Remove unnecessary version check

Bug 237426 updates Pillow to 6.0.0, which removed the Image.VERSION
variable, after a period of deprecation.

Cinnamon currently uses this variable, so backport upstream commit
c843f3664064742e2672e0fea528571a882d84ad [1] to compensate, so we don't
need to wait for the Gnome teams Cinnamon 4 update, which has already
pulled it in. Thanks to Charli Li for pointing this commit out.

While I'm here, fix all stage-qa errors and ports/framework compliance
issues:

  • Add missing LIB_DEPENDS
  • Add missing USE_{GNOME,X11} components
  • Add USES=gnome, gl
  • Fix gstreamer dependencies (GSTREAMER1, not GSTREAMER)
  • Add LICENCE{_FILE}
  • Fix more/all shebangs, remove custom REINPLACE_CMD section
  • Remove GH_ACCOUNT (no longer necessary)

[1] https://github.com/linuxmint/cinnamon/pull/8496
[2] https://github.com/linuxmint/cinnamon/issues/8495

PR: 238070, 237426
Reported by: kai
Tested by: Michal Kilijanek (via Twitter)
Approved by: kwm (gnome, maintainer)

Approved by: ports-secteam (blanket(s): bugfixes, dependencies)

Details

Committed
koobsJul 1 2019, 6:17 AM
Parents
rP505537: security/ipsec-tools: fix aggressive mode tunnels with wildcard-psk config
Branches
Unknown
Tags
Unknown