HomeFreeBSD

- Add USES=samba to handle dependency on samba

Description

  • Add USES=samba to handle dependency on samba Valid ARGS: build, env, lib, run (default: build,run)
  • Add SAMBA_DEFAULT to bsd.default-versions.mk (default: 4.3)
  • Remove obsolete samba36 ports
  • Modify samba4x ports to install libsmbclient
  • Convert the ports tree to USES=samba

Reviewed by: mat
Differential Revision: https://reviews.freebsd.org/D8919

Details

Committed
antoineMar 21 2017, 9:59 PM
Reviewer
mat
Differential Revision
D8919: USES=samba
Parents
rP436658: Upgrade to 1.5.29.
Branches
Unknown
Tags
Unknown