Page MenuHomeFreeBSD

make set_buswide() generic
ClosedPublic

Authored by br on Jul 28 2020, 1:35 PM.
Tags
None
Referenced Files
Unknown Object (File)
Thu, Apr 3, 7:15 AM
Unknown Object (File)
Feb 24 2025, 8:24 PM
Unknown Object (File)
Feb 23 2025, 6:31 PM
Unknown Object (File)
Feb 22 2025, 10:18 AM
Unknown Object (File)
Feb 22 2025, 2:19 AM
Unknown Object (File)
Feb 21 2025, 11:21 AM
Unknown Object (File)
Feb 18 2025, 12:30 PM
Unknown Object (File)
Dec 29 2024, 10:24 AM
Subscribers

Details

Summary

Rename these functions:

bus_dma_dmar_set_buswide()
dmar_is_buswide_ctx()
dmar_set_buswide_ctx()

Not really sure if they are needed for SMMU, but we need to build them on arm64 at least

Diff Detail

Repository
rS FreeBSD src repository - subversion
Lint
Lint Not Applicable
Unit
Tests Not Applicable

Event Timeline

br requested review of this revision.Jul 28 2020, 1:35 PM
br created this revision.

Rename bus_dma_dmar_load_ident() as well

So please plan for the following two next changes:

  1. Removal of headers from iommu.h
  2. Providing the vtable for implementation of map/unmap to be used from iommu_gas.
sys/dev/iommu/iommu.h
41 ↗(On Diff #75068)

sys/types.h should go first.

43 ↗(On Diff #75068)

I think that bringing all that headers into iommu.h was the wrong idea. All of that should be removed and provided by the header' consumers.

This revision is now accepted and ready to land.Jul 28 2020, 3:40 PM