Page MenuHomeFreeBSD

net-mgmt/collectd5: Update to version 5.7.1
ClosedPublic

Authored by jrm on Feb 4 2017, 6:16 PM.

Details

Summary

net-mgmt/collectd5: Update to version 5.7.1

PR: 216670

Other Changes:

  • Remove unnecessary global BUILD_DEPENDS, LIB_DEPENDS and RUN_DEPENDS
  • Redo patches to fix portlint warnings
  • Fix linked library errors reported by poudriere

Remaining issue:

  • When the XMMS option is selected, xmms.so is linked to libraries in devel/glib12 and x11-toolkits/gtk12, but adding XMMS_USE=GNOME=glib12,gtk12 causes a build error.
Test Plan

portlint -C: OK
testport: OK (poudriere: 10.3-RELEASE-p10, i386, default options)
testport: OK (poudriere: 10.3-RELEASE-p10, amd64, default options)
testport: OK (poudriere: 11.0-RELEASE-p1, i386, default options)
testport: OK (poudriere: 11.0-RELEASE-p1, amd64, default options)

Diff Detail

Repository
rP FreeBSD ports repository
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.

Event Timeline

jrm updated this revision to Diff 24731.Feb 4 2017, 6:16 PM
jrm retitled this revision from to net-mgmt/collectd5: Update to version 5.7.1.
jrm updated this object.
jrm edited the test plan for this revision. (Show Details)
jrm added reviewers: swills, AMDmi3.
jrm updated this object.Feb 4 2017, 6:16 PM
jrm updated this revision to Diff 24748.Feb 4 2017, 10:29 PM

Fix typo GI_RUN_DEPENDS -> CGI_DEPENDS.

jrm updated this revision to Diff 24749.Feb 4 2017, 10:31 PM

Fix typo GGI_RUN_DEPENDS -> CGI_RUN_DEPENDS.

swills accepted this revision.Feb 6 2017, 4:45 PM
swills edited edge metadata.

Looks good, approved.

This revision is now accepted and ready to land.Feb 6 2017, 4:45 PM
This revision was automatically updated to reflect the committed changes.