Page MenuHomeFreeBSD

Remove support for expired linux-f10 ports
ClosedPublic

Authored by rene on Nov 27 2016, 10:03 PM.

Details

Summary

The linux-f10-* ports will expire on 2017-01-01, remove support for them from Mk/Uses/linux.mk by that time.

While here, simplify the check for 64-bit Linux since only FreeBSD 10.3 and 11.0 will be officially supported by then.

All individual */*f10* ports and games/dsnake (which is linux-f10-only) also have to be removed.

Test Plan

make index passes

Diff Detail

Repository
rP FreeBSD ports repository
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.

Event Timeline

rene retitled this revision from to Remove support for expired linux-f10 ports.
rene updated this object.
rene edited the test plan for this revision. (Show Details)
rene added a reviewer: emulation.
rene set the repository for this revision to rP FreeBSD ports repository.

Does anyone from portmgr or emulation have any comments or is it fine to commit this after 2016-12-31 ?

Perhaps I should not commit the changes in line 43 and 45 of Mk/Uses/linux.mk yet, it can be argued that dropping support for 9.3/10.1/10.2 is a separate thing.

bapt added a reviewer: bapt.
rene added a reviewer: rene.

Self-accepting after bapt's review

This revision is now accepted and ready to land.Dec 31 2016, 4:46 PM
This revision was automatically updated to reflect the committed changes.